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AidTrans Studio Overview  

AidTrans Studio  is a CAT tool, translation memory tool. Other names for translation memory tool are: 
translation memory system, translation memory application or translation memory software.  
It provides translation editor to translate different formats in one easy to use environment, tools to manage 
both translation memory databases (tm) and terminology databases (tdb), and a set of useful utilities for 
tasks related to translation process.  
 
AidTrans Studio  is designed for freelance translators as well as translation services providers like 
translation companies, localization companies or corporate translation departments. The application 
architecture is based on Microsoft .Net Framework, the latest achievement in software development for 
Windows platform. 
 
AidTrans Studio  belongs to the so called CAT tools, as it provides ‘aid’ for the translation process. In 
general translation memory tools are part of a large family of software tools called translation tools or just 
tools for translators. Of course, there are many types of software tools for translators, but tm tools belong 
definitely to the most important ones. 
 
Translation memory  (TM) and Terminology database integrated . There is no separate software tool for 
terminology lookup. When translating with AidTrans Studio translation editor you can easily search both TM 
and TDB databases.  

Supported file formats  

 
1) Microsoft Word 2003 Xml files (*.xml). Any file format supported by Microsoft Word can be saved to 

.xml and translated using AidTrans Studio Basic Edition.  
Microsoft Word is not required to be installed to process Microsoft Word Xml files in AidTrans 
Studio. 
 
Microsoft Word .doc files can be easily saved to Microsoft Word 2003 Xml format. To save .doc file 
as .xml start Microsoft Word 2003, open file, then select File > Save As.  In Save As window in 
format combo box select Document XML (*.xml). 
 
While saving file to XML, all the format information is preserved. You can also specify XML as the 
default format for Microsoft Word using its options.  
 

2) HTML Documents (*.html,*.htm,*.php,*.jsp,*.asp,*.aspx,*.ascx). 
3) XML files (*.xml). 
4) TTX Files (*.ttx), note that files must be segmented. 
5) Odt files (*.otd) created e.g. by OpenOffice Writer 2.0 or higher, note that .odt is default OpenOffice 

Writer file format. Any file that can be opened by OpenOffice, can be saved to odt.  
OpenOffice Writer is not required to be installed to process .otd files (*.otd) in AidTrans Studio. 
 
Note that Microsoft Office version 2007 supports Odt documents format, so any .otd file can be 
opened and saved to .doc or .xml, also any .doc file can be saved to .otd format to open with 
OpenOffice. 

6) Microsoft Excel 2007 (*.xlsx,*.xltx,*.xlsm). 
7) Custom files (*.*). To prepare custom files for translation you need to use AidTrans Studio utilities. 

AidTrans Studio Setup  

System requirements: 
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AidTrans Studio 2.0 runs under Windows Vista, Windows XP or Windows 2000. Formerly operating system 
generations such as Windows NT and Windows 98 are no longer supported. 
 
To install AidTrans Studio 2.0 Basic: 
 

1. Download Basic Edition setup file: AidTransStudioBasic2.0.zip from AidTrans Soft website 
download section. 

2. Extract files from zip archive to a folder on your hard drive, e.g. C:\ATStudioSetup\. 
3. Run Setup.exe. 
4. Follow the installation wizard instructions to complete application setup. 

 
Note: It is highly recommended to accept the default installation folder: C:\AidTransStudioBasic2\. 

AidTrans Studio Basic Overview  

AidTrans Studio Basic edition is designed for freelance translators that do not use translation memory 
software one everyday basis.   
 
AidTrans Studio Basic key futures: 

�  free of charge edition for both private and commercial use, 
�  local tm/tdb support, 
�  no language limitations, you can use any source-target language combination (over 100 

languages), 
�  supports Translation Kits created in AidTrans Studio Enterprise edition. 

 
AidTrans Studio limitations: 

�  you can use only one Translation Memory database can be used in project, ( with Professional 
edition you can use two TMs, one updatable and one read-only), 

�  you cannot use Network TM, 
�  for import/analyze/pretranslation of a new file you cannot use TM that contains more than 2000 

units, 
�  you can select only one file for import/analyze/pretranslate. 

Translation Workflow  

Prepare Reference Materials  
Import existing translation memory databases and terminology databases. 
How to import data into translation memory database (tm). 
How to import data into terminology database (tdb). 

Create Project  
Project is a set of files with common tm and tdb databases and other configuration parameters sets. 
How to create new project 

Prepare New Files for Translation  
Read more on how to prepare file for translation. 
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Translate  
Read more about Translation Editor. 
See how you can customize translation environment with application options. 

Proofread  
Perform manual text proofreading within translation editor. Read more about proofreading features 

Check tags in files  
To avoid any problems when exporting files, perform verification of tags in files. Read more about how to 
verify tags in files 

Prepare files for translation  

The first step to translate file is to prepare file for translation. We undergo the same procedure to analyze 
files and get log file with word count information. 
 

 
 

 
 

Translation workflow in AidTrans Studio. 
 
Steps to prepare file for translation: 

Select File > Prepare for Translation , or click  button. Prepare for translation window pops up. 
 

Xml files Xml files, in target 
language 

Import: Translatable text 
extraction 

Export: Translated text put 
back in Xml files 

ats file 

Tagged file for translation 



 

AidTrans Studio Basic 2.0   Page 10 of 88 

 
Import/Prepare Files for Translation main window, F ile Selection Tab. 

File Selection Features  

Add files to prepare/analyze  
 
 

Click  button to select file to analyze/prepare for translation, select appropriate file format and 
browse to files, then click OK button. 
 
Note: using Basic edition you can select only one file for single import process.  

Add all files in folder  
 

To add all files in selected folder and all subfolders click  button, Select folder to add  window 
pops up. 
 

 
Select folder to add window. 
 

1) To select folder to add click  button and then browse to folder, 
2) Select file formats that are present inside the specified folder which you wish to add to import files 

list, 
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3) All the filenames of files that are present in selected folder and match the specified format, are 
displayed in the grid. To add these files to the import files list, click OK button. 

 
Note that you can specify more then one file format. The only limitation occurs when files of different import 
formats have the same extensions, e.g. .xml files and Ms Word Xml files. Ms word Xml files are processed 
with specific .xml import files and the .xml files are processed with generic configurable .xml import filter, so 
you need to decide which type of the files is valid for the selected folder.  
 
Note that this feature is not active in Basic edition. 

Exclude File  

To exclude selected file from import file list click  button.  
 

Clear File List  

To exclude all files from import grid so that they are not included for import any more, click  
button. 

Load Last Selected Files List  

To restore last selected files list for import, click  button. Note that information about 
batches assignment for files will also be restored. 
 
 

Import/Prepare for translation Option  

 
You can use set of options to customize import process. 
 
File Selection Tab Options: 

 

Prepare Files Option  

 
If enabled, files are prepared for translation and placed in the 
{ProjectFolder}\Translation\{SourceTargetLngCode}\ folder. 
Note that while importing file, .ats file is created in the structure which is similar to import folder structure, 
e.g. 
Source File: \Import\Test\Sample\ Sample2.odt 
Translation file: \Translation\ENG_DEU\Test\Sample\ Sample2.ENG.ats 

   \Translation\ENG_DEU\Test\Sample\ Sample2.DEU.ats 
The relative path: \Test\Sample\ is identical. 
 
When file is selected from outside of import folder of current project, translation file is created in root folder 
for selected source and target language.  
 
Source File: c:\Test\Sample\Sample2.odt 
Translation file: \Translation\ENG_DEU\Sample2.ENG.ats 

   \Translation\ENG_DEU\Sample2.DEU.ats 
 

Option PreTranslate   
 

When option is enabled and match value exceeds Put Matches Threshold  option value defined in 
Application Options > Pretranslation tab , they are put in translation document. 
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For instance, if: PreTranslate option in import window is checked and Put Matches Threshold  will be set to 
100%, only 100 % matches will be put in target document. 

 

Option Analyze only  

 
When analyze option is enabled, no files are created in translation folder and the only output of the process 
is log file with precise information about number of words/characters to translate as well as repetitions 
present in analyzed files. 
 
Note that when this option is enabled, PreTranslate option is not applicable. 
 

Import files: Tm options  

 
Import/Prepare Files for Translation main window, T m tab. Network TM Selection panel is 
enabled only in Enterprise Edition. 

Source Language  
Source Language for current files import/analyze process. 
 

Target Language  
Target Language for current files import/analyze process. 
 

Load Default TMs  
Loads Tm databases that are defined as default for current source/target language. 
 
To define particular databases as default: 

1) Run prepare for translation window and select Tm tab, 
2) Select source and target language, 
3) Select tm databases you wish to make default for selected languages, 
4) Click Save Selected TMs as Default button. 

 

Save Selected TMs as Default  
 
To save currently selected TMs as default for selected source and target language, click Save Selected 
TMs as Default  button. 

Local Tm Selection panel  
Project TM database  – primary tm database to use when importing/preparing files for translation. 
Reference TM database  – reference tm database to use when importing/preparing files for translation. 
 
Select Tm that you wish to use and click OK button. 



 

 

Enable Repetitions Extract  
If the option is enabled, segments that occur the number of times that is defined by Repetitions Extract 
Threshold  parameter value, are copied to the repetitions extract file. For example, if Repetitions Extract 
Threshold is 2, all the segments that occur at least twice in imported files, are copied to repetitions extract 
file. 

Repetitions Extract File Path  
Path to file which contains repetition. 

File Format Options  
These options specify how AidTrans Studio handles files during import. Read more about file format 
specific options. 

Advanced Options  

Placeables Config Name  
Select placeables configuration name to apply when preparing files for translation or analyze process. 
 

Segmentation Config Name  
Select segmentation configuration name to apply while preparing files for translation or analysis process.  

Additional Segment Attributes  
Additional information useful for segment processing within AidTrans Studio.  
 
Save User Defaults – saves current settings as user defaults. 
Load User Defaults – loads settings saved by the user. 
Load Defaults – loads application defaults. 

Toolbars – main application window  
AidTrans Studio main window toolbars: 

Toolbar Main   
Main toolbar provides application major features.  

 
 

Icon     

 
Prepare Files for 
Translation 

Runs Prepare File for Translation window  

 
New Project Runs Create New Project  window 

 
Open file 1)     To open file click or select File  > Open  item from menu.  

2)     Browse and select file to edit, then click open button. 

 
Close File Closes currently opened file. 

 
Save changes 
 

To save changes to current file click this button or select File  > 
Save or press Ctrl+S .  
 

 
Export Translated File Runs Export Files window. 

 Cut Cuts selected text fragment. 

 Undo Action To Undo action click this button or select Edit > Undo or press 
Ctrl+Z . Note that first you must set cursor in appropriate window. To 
undo action in target file, first move cursor to target file window then click 
Undo  button.  
 

 Redo Action To Redo action click this button or select Edit > Redo  or press 
Ctrl+R . 
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 Find Find text in currently opened file. 

 Copy Segment source to 
target 

Copies source text of current active segment to target segment. 
This function is useful if you wish to restore the source text in 
segment for some reason. 

 Tm Manager Runs Tm Manger. 

 Tdb Manager Runs Tdb Manager. 

 Options Runs Application Options. 

 Edit Project Runs Edit Project window. 

  Zoom Factor You can select zoom factor for currently opened file. 

 

Toolbar Segment Navigation  
Segment navigation toolbar provides an easy way to navigate within segments in current document. 

 
 

Icon     

 Next segment Selects next segment. If option Auto search TM entries when 
segment activated  is checked, tm search will be performed.  

 Previous segment Selects previous segment 

 Next doubtful segment Selects next segment with status Doubtful. 

 Previous doubtful 
segment 

Selects previous segment with status Doubtful. 

 Next Translatable/Get M Goes to the following translatable segment and performs Tm 
matches search in data sources specified for the project. If option 
Consider 100 matches translatable  is checked, it stops at 100 % 
matches, if unchecked, it skips 100% matches segments. 

 
Set tr./Up Tm/Next/Get M 1. Sets segment status to Translated , 

2. Sends segment to Tm database, 
3. Goes to the following translatable segment, 
4. Performs Tm matches search in data sources specified for the 

project. 

 Next 100% match 
segment 

Selects next segment with 100% match (Exact match) status. 

 Previous 100% match 
segment 

Selects previous segment with 100% match (Exact match) status. 

 Next fuzzy match 
segment 

Selects next segment with fuzzy match status. 

 Previous fuzzy match 
segment 

Selects previous segment with fuzzy match status. 

 
Next Segment/Get 
Matches 

Selects next segment and gets matches from Tm Database. 

 Next Segment/Send to 
Tm/Get Matches 

1. Changes status of current segment to Translated , 
2. Updates current segment into currently opened project 

translation memory database, 
3. Moves to next translatable segment, 
4. Gets tm and tdb matches for segment. 

 Next Translated 
Segment 

Selects next segment with status Translated . 

 Previous Translated 
Segment 

Selects previous segment with status Translated . 

 Next Untranslated 
Segment 

Selects next segment with status Untranslated . 

 
Previous Untranslated 
Segment 

Selects previous segment with status Untranslated . 

 
Next Segment with 
Comment 

Selects next segment with non-empty comment. 

 Previous Segment with 
Comment 

Selects previous segment with non-empty comment. 

 
Go To Segment  Type segment number you wish to navigate to and click   

button, segment with specified number will be selected. 
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   Set segment status 
Translated 

 Sets the status of current active segment Translated  

      
 

Toolbar Proofreading  
Proofreading mode replaces default segment navigation toolbar with proofreading toolbar that provides 
functions more useful while proofreading files.  
Proofreading requires a bit different toolset than translation. To switch to proof mode select View > 
Proofreading Mode . 
 

 
Proofreading toolbar 
Segment navigation in proofreading mode. 

Icon     

 Next segment Select next segment. If option Auto search TM entries when 
segment activated  is checked, tm search will be performed.  

 Previous segment Selects previous segment 

 Set proof/Update 
Tm/Next proofable/Get 
matches 

1. Changes segment status to Proofread , 
2. Updates tm with current segment value, 
3. Moves to next proofable segment (with status other then 

proofread), 
4. Gets tm matches and terminology for next segment. 

  Next proofable/Get 
matches 

1.      Move to next proofable segment (with status other then 
proofread), 

2.      Gets tm matches and terminology for next segment. 

 
Next doubtful segment Selects next segment with status Doubtful.  

 Previous doubtful 
segment 

Selects previous segment with status Doubtful . 

 Next doubtful segment Selects next segment with status Doubtful.  

 
Previous doubtful 
segment 

Selects previous segment with status Doubtful.  

 Set segment status 
proofread 

Sets the status of current segment Proofread.  

 
After proofreading is completed, all the segments should have status Proofread . Usually the person who 
proofreads the text is more experienced and should be able to deal with all the doubtful segments. 

Toolbar Tm/Tdb Interoperation  
With Tm/Tdb toolbar you can run tm/tdb functions. 

 
 

Icon     

 Initialize Tm/Tdb 
Environment 

Starts Tm/Tdb data environment so you can search/update data 
sources for the project. Note that before you can search matches in 
Tm database you need to click this button.  
 
Once Tm and Tdb data is loaded, the information about number of 
rows in each database defined as reference for current project is 
displayed. 

 Find matches in Tm Performs matches search in translation memory databases defined 
as data sources for current project. If match value is higher than 
defined threshold, it is displayed in translation memory matches 
window. 

 Add Tm Entry Runs Add new translation memory database entry row window, 
(source and target only). 

 Update Project Tm Saves changes to project translation memory database. 

 Get Tdb Data Performs search of all words and phrases that current segment 
contains and displays results in Terminology matches window. 

 Add Tdb Entry Runs Add new terminology database entry row window, (source 
and target only). 
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 Update Project Tdb Saves changes to project terminology database. 

 Get Tm Matches and 
Terminology 

Gets Tm matches and terminology for current segment. 

 Tm/Tdb concordance 
search 

Runs concordance search window. 

 
Refresh Tm/Tdb Data Refreshes translation memory and terminology data. To be applied 

when working with network Tm/Tdb database to use the most 
current data. 

Tm matches panel  

 
If there is more then one match found the first match with the highest Match Value is displayed in Match 
Details panel. 
 
Matches list columns: 

�  Value [%] – match value for matches list row, 
�  Match source text – source text for matches list row, 
�  Match target text – target text for matches list row, 

- copy target match text (3) into target document window, 

 - copy target match text (3) into target document window, navigates to next translatable segment and 
gets matches. 
 
The part of match text that is not present in the segment text is highlighted in the Match source text box (1), 
see screen below: 
  

  
 
If there are tags in the match source that are not present in the segment text (these tags are to be 
removed), they are highlighted. In the screen below these tags are highlighted with red. 

 

(1) Match source text 

(2) Match source text 

Tags to be placed in target text 

(3) Target text, if match value is less 
than 100 % correct target text  



 

 

AidTrans Studio User Interface  

In AidTrans studio for each translation file there are actually two files created on disc: one containing 
source text and another one containing target text. 
 
Note:  File name must match pattern: <FileName>.<Language Code>.ats 
Proper file name sample for source language English and target language German: 
Source file name: SampleFile.ENG.ats   
Target file name: SampleFile.DEU.ats 
 
Note that filename must be identical for source and target language.  For example, if you rename 
SampleFile. ENG.ats to SampleFile1. ENG.ats, and leave target file name unchanged SampleFile.DEU.ats, 
the file will not be recognized as valid translation file. 
 
Files for each source and target language are stored in specific folder of current project, e.g. files from 
English into German are stored in \Translation\ENG_DEU\ because ENG is English language code and 
DEU is German language code. 

Translation Editor User Interface  
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Translation Editor User Interface. 
  

1)     Menu bar and toolbars, 
2)     Source File Text - source text is displayed in this window, 
3)     Target File Text - translation is put in this window, 
4)     Translation memory matches window, 
5)     Terminology database matches window, 
6)     Additional segment information window. 

Tm/Tdb Selection toolbar  
With Tm/Tdb selection toolbar you can easily decide which translation memory database and terminology 
database is to function as the reference for translation. 
To select Tm database, click Open Tm  button (red frame on the screen below) and browse to file. 
To select Tdb database, click Open Tdb  button (blue frame on the screen below) and browse to file. 

Tm/Tdb Selection Toolbar 
 
Note: You can also select translation memory in project data and Tm/Tdb selection toolbar makes it easier. 
To select Tm database in project data, select: Projects > Edit Current Project > Translation Memor y tab. 
To edit terminology databases for current project, select: Projects > Edit Current Project > Terminology  
tab. 

Menu Bar  

Menu File   

 
 Item  Key  Description 

 
Prepare for Translation Ctrl+N Runs Prepare for Translation  window. 

 Open Ctrl+O Opens .ats file.  

 Close Doc Ctrl+F4 Closes currently opened file. 

 Export translated files  Runs Export Files window. 

 

Save Ctrl+S Saves changes in current target .ats file. Note that 
changes in source file are saved only if option Source 
Document Read only is unchecked. 

 Print Ctrl+P Prints source or target window contents. 

 
Print Preview  Preview for source or target printout. 

 Page setup  Page setup for printout. 

 
Open Translation Kit File  Opens translation kit file and imports its contents. 

 Exit  Exits AidTrans Studio. 
    

Menu Edit  

 
 Item  Key  Description 

 Undo Ctrl+Z Undoes the last action in translation editor. 

 Redo Ctrl+Y Redoes the last action in translation editor. 

 Cut Ctrl+X Cuts selected text. 

 Copy Ctrl+C Copies selected text to the system clipboard. 

 Paste Ctrl+V Pastes current clipboard contents. 
 Find Ctrl+F Finds specified text in currently opened document. 
 Replace Ctrl+H Runs Replace window.  
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Menu Segment   

Functions that apply to active segment. 

 
 Item  Key Description 
 Join with next segment  Joins active segment with next one. Command will not 

succeed if there is an object tag between segments. 
 Join with prev segment  Joins active segment with previous one. Command will 

not succeed if there is an object tag between segments. 
 Split segment  Splits segment at current cursor position. 
 Change Segment Status to  Changes active segment status. 
 Set Status Translated to all  Sets status translated (confirms) for all segments with 

selected status. 
    

 

Menu Navigation   

 
 Item  Key  Description 

 Next segment Ctrl+NumPad2 Navigates to next segment. 

 Previous segment Ctrl+NumPad2 Navigates to previous segment. 

 

Next Translatable/Get M Alt+Right Goes to the following translatable segment and 
performs Tm matches search in data sources 
specified for project. If option ‘Consider 100 
matches translatable’ is checked, it stops at 100 % 
matches, if unchecked, it skips 100% matches 
segments.  

 

Set tr./Up Tm/Next/Get M Alt+Down 5. Sets segment status to ‘Translated’, 
6. Sends segment to Tm database, 
7. Goes to the following translatable segment, 
8. Performs Tm matches search in data sources 

specified for project. 

 

Next Proofable/Get M Ctrl+Right 1.  Goes to the following proofable segment. 
2.  Performs Tm matches search in data           
sources specified for project. 

 

Set proof./Up Tm/Next/Get M Ctrl+Down 1. Sets segment status to Proofread, 
2. Sends segment to Tm database, 
3. Goes to the following proofable segment, 
4. Performs Tm matches search in data sources 

specified for project. 
 

 Next with comment Ctrl+NumPad1 Next segment with non empty comment. 

 Previous with comment Ctrl+NumPad4 Previous segment with non empty comment. 
    

 
Next Untranslated  Activates next segment with status 

Untranslated. 

 
Previous Untranslated  Activates previous segment with status 

Untranslated 

 
Next Doubtful  Activates next segment with status 

Doubtful. 

 
Previous Doubtful  Activates previous segment with status 

Doubtful. 

 
Next Exact match  Activates next segment with status 

Exact match. 

 
Previous Exact match  Activates previous segment with status Exact 

match. 

 
Next Fuzzy match  Activates next segment with status 

Fuzzy match. 

 
Previous Fuzzy match  Activates previous segment with status 

Fuzzy match. 
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Menu View   

 
 Item  Key  Description 
 Layout settings  Starts Layout settings edit window. 
 Tags View Options  Starts Tags view options edit window. 
 Proofreading Mode  Turns on proofreading mode  - shows proofreading 

toolbar and hides translation toolbar. 
 Toolbars  You can show/hide toolbars in main AidTrans Studio 

window.  
    

Menu Tools   

 
 Item  Key  Description 

 Spell check   
- Open File in Ms Word  Opens target language file in Ms Word for spell check. 
- Copy File Path to Clipboard  Copies current file to clipboard. 
 Analyze  Runs Analyze files window which works very similarly to 

Prepare for translation window. The only difference is 
that .ats files are not created and only log file with 
analyze results is created.  

 
Current File Statistics  Presents statistics for currently opened file. 

 Project Statistics  Presents statistics for all files in project. 
 Tags Verification  Runs Tag Verifier. 

 
Options  Runs Application Options window. 

 Segmentation Config  Runs Segmentation configuration window. 

 Placeables Config  Runs Placeables configuration window. 
    
    

Menu Projects   

 
 Item  Key  Description 

 Explore project folder  Opens current project folder. 

 Edit Current Project  Runs Edit project window. 
    

 
New Project  Runs create new project window. 

 Load Project  Runs Project load\delete window. 
 Create file to send translation  Creates zip file that contains all .ats files \Translation 

folder.   
    

Menu TM/TDB    

 
 Item  Key  Description 

 
Initialize TM\TDB data 
environment 

 Loads translation memory data as well as terminology 
data so that you can perform translation memory and 
terminology search. 

 Refresh Tm/Tdb Data  Refreshes translation memory and terminology data. 

 Find terminology in TDB  Performs search of all words and phrases that current 
segment contains and displays results in Terminology 
matches window. 

 Find matches in TM  Performs matches search in translation memory 
databases defined as data sources for current project. 
If match value is higher than defined threshold, it is 
displayed in translation memory matches window. 

 
Find matches and terminology  Gets Tm matches and terminology for current segment. 
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 Concordance search Tm\Tdb  Runs Concordance search window. 
    

 
Add TDB Entry  Runs Add new terminology database entry row, (source 

and target only). 
 Add TDB Entry (all fields)  Runs Add new terminology database entry row, (source 

and target with all attributes). 
    

 Add TM Entry  Runs Add new translation memory database entry row, 
(source and target only). 

 Add TM Entry (all fields)  Runs Add new translation memory database entry row, 
(source and target with all attributes). 

 Tm Manager  Runs Translation memory manager. 

 Tdb Manager  Runs Terminology database manager. 
    

 Update Project Tm  Saves changes to project translation memory database. 

 Update Tdb  Saves changes to project terminology database. 
    

 

Menu Help   

 
 Item  Key  Description 
 Contents  Shows help contents. 
 Index  Shows help index. 
 Search  Shows help search page. 
 About  Shows AidTrans Studio version/release information. 
    

Menu Utilities   
Utilities are not available in Basic edition. 

 
 Item  Key Description 
 Regular Expression Test Utility  Runs Regular Expression Test Utility window. 
 AidTrans Studio Character Set 

Conversion Utility 
 Runs AidTrans Studio Character Set Conversion Utility, 

you can perform encoding conversion, e.g. ANSI to 
Unicode. 

 Translation Length Verifier  Runs Translation Length Verifier. 
 Custom File Format Settings  Runs Custom File Format Settings where you can edit 

settings for custom format. 
 Custom File Format Tagger  With Custom File Format Tagger you can apply custom 

format settings to selected files (single file in pro 
edition). 

 File Compare  Starts Character by character file compare utility.  
 Tm Servers Manager  Applicable only to Enterprise edition. 
 Tdb Servers Manager  Applicable only to Enterprise edition. 
    

 
 
 

AidTrans Studio workspace file formats  
AidTrans Studio workspace file types: 

ats files  
AidTrans Studio edit files (*.ats) are text files Unicode encoded, so any language supported by Unicode 
encoding is supported by AidTrans Studio. 
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It is possible to open .ats file in any text editor that supports Unicode encoding, e.g. Notepad , Microsoft 
Word or OpenOffice Writter. 

atm files  
AidTrans Studio translation memory database file. 

atd files  
AidTrans Studio terminology database file. 

Edit Features  
Open file  

1)     To open file click  button or select File  > Open  item from main menu.  
2)     Browse and select file to edit, then click Open button. 

Close File  

To close current file click  button or select File  > Close doc  item from files menu. 
  
Save changes  

To save changes to current file click  or select File  > Save  or press Ctrl+S .  
  
Undo Action  

To Undo action click  button or select Edit > Undo or press Ctrl+Z . Note that you must first set cursor in 
appropriate window, e.g.  to undo action in target file, first move cursor to target file window.  
 
Redo Action  

To redo action click  button or select Edit > Redo  or press Ctrl+R . 

Activate Segment  
To select segment: set cursor in desired text fragment, right click and select Activate Segment  from 
context menu. 
  
When segment is active, you can use find matches function in current translation memory and perform 
terminology search. 
 
Edit Features 

Additional Segment information  
 
There is some additional information on each segment in a target document: 
Um - user modified, Windows login of the user who last modified the segment. 
Dm – date modified, date and time of the last segment modification. 
Cm – comments, user’s comments for current segment.  
Rt – if segment is a repetition, segment text is in additional segment information window. 
 
Note that information about user and date of last segment modification is stored only if segment modified is 
an active segment (highlighted).  
 
Additional segment information box is displayed in the right-bottom corner of the translation editor 
workspace: 
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Spell check  

To start spell check for current file click  button or select Tools > Spell Check. 
 
Note that to start spell check on .ats files using Microsoft Word, you need to have Microsoft Word version 
XP or 2003 installed on your workstation.  
 
How to perform spell check with other text editor (e.g. OpenOffice Writer): 

�  Select Tools > Spell Check > Copy File Path to Clipboard , 
�  Run text editor, select File > Open  (or other command to open the file),  
�  Paste file path from clipboard using Ctrl V in the opened dialog window, accept and proceed to 

open the file. 
Note: Do not modify any of AidTrans Studio Tags when performing spell check. All expressions like � *� , 

‹*›,«*»   (where * means any text string)  are AidTrans Studi o tags and should not be removed 
from the translation file or modified . 

Find/Replace Text  

To find specified text click  button or select Edit > Find  or just press Ctrl+F . 

 
Type text you wish to find in Find  box. 
 
Search Options 
 
Match case  – specifies if search will be case sensitive. 
Match whole words only – finds only full words matches. 
 
Replace Text  
To replace text press Ctrl+H  or select Edit > Replace.  
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Segment Status Change  
To change segment status: select segment, then Segment  > Change Segment Status to  > {Desired 
Status} 
  

Join Segments  
To join segments: select segment to join, select: Segment > Join with next segment (to join with next 
one) or Segment > Join with prev segment (to join with previous one). 
  
Note: You cannot join segments if there is an object tag between the segments.  

Split Segment  
To split segment: 

1) Place cursor in source  document window, at the exact position where new segment limit should be 
placed, 

2) Select Segment > Split Segment , or click right mouse button (at split point) and select Split 
Segment at cursor.  

 
Note that splitting segment changes identifiers of segments following current segment. For instance, if you 
split segment no. 6, segment no. 7 will become 8. 

Translation Memory usage  
The following section covers all the topics related to tm or tdb database.  

Initialize tm/tdb environment  

Click  button to load translation memory and terminology data, so it is possible to perform matches 
search as well as concordance search.   
Note that without initializing tm/tdb environment you cannot perform any operation on translation memory. 

Find matches in translation memory  

To find matches for segment, first you need to select it and then click  on tm/tdb toolbar, or select 
Tm/Tdb > Find matches in TM. Note that only matches with hit rate above defined Min hit rate for fuzzy 
matches option value will be displayed in tm matches window. For instance, if the threshold for fuzzy 
matches is 75% and match value is 79%, the match will be displayed.  

Find matches and terminology for segment  

To find translation memory matches and terminology for active segment click  button. It gets both 
matches in translation memory and terminology database. 
 
You can also activate segment and find translation memory matches and terminology database matches in 
one step. Place cursor at segment you wish to find matches for click right mouse button and select  
Activate/Get Tm/Tdb  matches item (see screen below). 
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If there are matches found in the translation memory you can see them in Tm matches panel: 

Match Value  

Match value determines how similar is match found in the Tm to current segment text. 

Internal tags 

Find terminology for current segment  

To find all matches in terminology database click  button. This function performs search in tdb database 
for each word in current segment. Tdb matches engine splits the segment text into words and performs 
search for each of them. 
Note that results returned by function are limited by Minimum priority of tdb entries to display option value. 
Only entries with Priority attribute value higher than specified option value, will be returned by terminology 
search function. 
 
Sample: 
Segment text: The small nice rat was caught by an ugly cat. 
Entries in project tdb found for current segment: 
 
Source Text Priority Comment 
caught by 6  
nice 2  
ugly 2  
rat 5  
   
small rat 7 Not returned by search function as it 

does not match the exact fragment 
of the segment text.  

 
Option Minimum priority of tdb entries to display  value is 5, so all matches with Priority  value below 5 
will be filtered out. 

Concordance Search Tm\Tdb  
To start concordance search window select TM\TDB > Concordance search Tm\Tdb. Note that 
concordance search performs lookup both in translation memories and terminology databases specified for 
current project.   
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Translation Memory/Terminology database concordance  search window.  
 

To customize concordance search options, click  button. 
 
Concordance search options: 

-Search in source column , if checked, source language column is included in search, 
-Search in translation column, if checked, target language column is included in search, 
-Search in Project Tm, tm database defined as project tm is included in search, 
-Search in Reference Tm,  tm database defined as reference tm is included in search, 
-Search in Project Tdb,  tm database defined as project tdb is included in search, 
-Search in Reference Tdb,  tdb database defined as reference tdb is included in search. 
 

For each database assigned to project you can define maximum number of rows to be returned by 
concordance search. 

After customizing option you can click  button to hide options panel. 
 
The fragment of text found that is equal to expression sought is highlighted in red. 

Add New Entry to Translation Memory  
To add new segment to current project Translation Memory select Tm/Tdb > Add Tm Entry , the Add New 
Segment  window pops up. 
 
Type or paste source text for new entry in TextSrc  row, in Value  column (red frame on screenshot below). 
Target text must be placed in TextTgt  row, in Value  column (blue frame on screenshot below). 
 

 
Add segment to tm window 

To add whole segment into tm, activate segment then click:  button or select Tm/Tdb > Add TM Entry.  
 
The easiest way to add part of current segment  text as a separate segment into tm:  

1)     Select text to add to tm both in source and target window (see screenshot below), 
 

 
 

2)     Click Add Tm Entry   button or select Tm/Tdb > Add TM Entry,  
3)     You can edit source and translation text in popup window, 
3) To confirm, click OK. 

4) To save changes in Translation Memory Database click Update Project Tm   button or select 
TM/Tdb > Update Tm . 

 

 

Note that segments added with Translation Editor go to project translation memory database. Reference 
translation memory cannot be modified from Translation Editor, it can be modified only with Translation 
Memory Manager. 
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To add entry with enabled edition of all columns select Tm/Tdb > Add TM Entry (All fields). Then you can 
edit values for all columns (fields) in a new row to be added into translation memory database. 

Add New Entry to Terminology Database  
To add new segment to current project Terminology Database select Tm/Tdb > Add Tdb Entry , the Add 
New Entry  window pops up. 
 
Type or paste source text for new entry in TextSrc  row, in Value  column (red frame on screenshot below). 
Translations text must be placed in TextTgt  row, in Value  column (blue frame on screenshot below). 
 

 
Add segment to Terminology Database 

To add whole segment into tdb, activate segment then click:  button or select Tm/Tdb > Add TM Entry.  
 
  
The easiest way to add part of current segment  text as a separate segment into tm:  

1)     Select text to add to tm both in source and target window (see screenshot below), 
 

 
 

2)     Click Add Tdb Entry  button or select Tm/Tdb > Add Tdb Entry,  
3)     You can edit source and translation text in popup window, 
5) To confirm, click OK. 
6) To save changes in Terminology Database click Update Project Tdb  button or select TM/Tdb > 

Update Tdb.  
 

 
 
To add entry with enabled edition of all columns select Tm/Tdb > Add Tdb Entry (All fields). Then you 
can edit values for all columns (fields) in a new row to be added into terminology database. 

Update translation memory  

To save changes in translation memory click  on tm/tdb toolbar or select Tm/Tdb > Update Tm . 

Segment Status Workflow  
Segment status at each step of translation workflow. 
 

Note that entries added with Translation Editor go to project terminology database. Reference terminology 
database cannot be modified from Translation Editor, it can be modified only with Translation Memory 
Manager. 



 

AidTrans Studio Basic 2.0   Page 28 of 88 

 

Statistics  

Current File Statistics  
To display statistics for file select Tools > Current File Statistics 
 

 
 
Read more about Statistics Items Description 

Project Statistics  
To display statistics for all files in project for specified source/target language select Tools >  
Project Statistics.  
 

Untranslated 

Untranslated 
Pretranslation  

100 % Match 

Fuzzy Match 

Translated Translation  Doubtful 

Proofread Doubtful Proofreading  
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Totals in summary sections are totals for all files in current project. 
 
If the project is multi language, e.g. the source is English, the target are German and French languages. 
 
Note that .ats files should be placed in translation folder in appropriate sub folder according to source and 
target language for each file, e.g. file pair: sample.ENG.ats and sample.DEU.ats  should be placed in folder 
<project folder>\ENG_DEU\. 

Statistics Items Description  
Some information on items that you can find in statistics. 
 
Types: 
 
Type Name Description 
Untranslated Number of units in Untranslated  segments. 
Fuzzy Matches Number of units in Fuzzy matches  segments, note that threshold value when match is 

considered as fuzzy is defined in Application Options: Put matches threshold 
option. Matches with lower value will not be copied to translation documents 
during pretranslation. 

100 % Matches Number of units in 100% matches segments.  
Repetitions Number of units in segments that repeat at least once in imported file. 
Pending Number of units in Pending  segments. 
Translated Number of units in Translated  segments. 
Total Total for current unit. 
 
Units: 
 
Unit Name Description 
Segments Number of segments for current type. Usually it is equal to number of sentences. 
Words Number of words for current type. 
Characters Number of characters for current type. 
Placeab:Words The number of words in placeables (non translatables) for current type. 
Placeable:Chars Placeables (not to translate) words for current type. 
 
For Type Untranslated: 
 
Untranslated Segments  
Number of segments with status untranslated. 
  
Untranslated Words  
Number of words in segments with status untranslated. 
  
Untranslated Characters  
Number of characters in segments with status untranslated. 
  
Untranslated Placeables Words  
Number of words in expressions recognized as placeables in segments with status untranslated. 
  
Untranslated Placeables Characters  
Number of characters in expressions recognized as placeables in segments with status untranslated. 
Hint: To copy statistics window content use Ctrl A  and Ctrl C  and then you can paste statistics content into 
any text editor, e.g. Windows Notepad. 

Sample Log file content  
Sample file name: WordCountSample.xml 
Sample file content: 
 
The simple wordcount sample no. 100000000000000000. 
 
Log file created during import: 
 
Type\Units     Segments       Words          Charac ters     Placeab:words   Placeable:Chars 
Repetitions    0              0              0              0              0 
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100 % Matches  0              0              0              0              0 
95-99 %        0              0              0              0              0 
85-94 %        0              0              0              0              0 
75-84 %        0              0              0              0              0 
65-74 %        0              0              0              0              0 
50-64 %        0              0              0              0              0 
New(No match)  1              5              26 (1)          1              16 
--------------------------------------------------- -------------------------------------- 
Total          1              5              26             1              16 
(1) – all characters in string without whitespaces 
 
As there is no match found in Tm database during import, all the numbers are in New (No match) Type. 
 
The total number of words is 5 (as 100000000000000000 string is counted as placeable) 
There is one expression recognized as placeable (number: 100000000000000000) that contains one word 
and 16 characters. 
 
Csv Log File 
For each log file there is a .csv log version created. It contains all the statistics for a file in a single row so it 
is easy to process data for accounting purposes. 
 
Applies to Enterprise edition only: 
If Batching mode  option value is set to Manual or Auto , there are two additional log files created when 
preparing files for translation:  
Batches import log file: yyyy-mm-dd_hh_mm_batch.txt 
Batches import log file (csv): yyyy-mm-dd_hh_mm_batch.csv 
 
These files contain batches files information and totals for each unit.  

Import Log  
Each unit row is a category to classify units in a document prepared for translation. 
 
Match types: 
Type Name Description 
Repetitions Number of units in segments that repeat at least once in imported file. 
100 % Matches Number of units in 100% matches segments.  
95-99 % Number of units in 95-99 % matches segments. 
85-94 % Number of units in 85-94 % matches segments. 
75-84 % Number of units in 75-84 % matches segments. 
65-74 % Number of units in 65-74 % matches segments. 
50-64 % Number of units in 50-64 % matches segments. 
New(No match) Number of units in new segments (no match found in Tm database). 
Total Total for current unit. 
 
Units: 
Unit Name Description 
Segments Number of segments for current type. Usually it is equal to number of sentences. 
Words Number of words for current type. 
Characters Number of characters for current type. 
Placeab:Words The number of words in placeables (non translatables) for current type. 
Placeable:Chars Placeables (not to translate) words for current type. 

Import options  

Supported file formats  
1) Ms Word 2003 Xml files (*.xml). Any file format supported by Microsoft Word can be saved to .xml 

and translated using AidTrans Studio Basic Edition. This format supports full .doc file structure, so 
when saving to .xml, you do not lose any formatting information. 
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2) Text files (*.txt). 
3) Odt files (*.otd) created, e.g. by OpenOffice Writer 2.0 or higher. Note that .odt is the default 

OpenOffice Writer file format. Any file that can be opened by OpenOffice, can be saved to .odt. 
Microsoft Office version 2007 supports Odt documents format, so any .otd file can be opened and 
saved to .doc, also any .doc file can be saved to .otd format to open with OpenOffice.  

4) Html files (*.html, *.htm) files. 
5) Ttx files (*.ttx). 
6) Xml files (*.xml). 
7) Custom files (*.*). Any files tagged with Tagger for Custom files utility. Any type of the files that is 

text based can be processed as custom file type in AidTrans Studio, e.g. properties, configuration 
files, delimited files. 

Import Options for different file formats  
For each file format there are some options for import process customization. This section is not applicable 
for basic edition as it uses simplified files import interface. 

Import Options Html files  

 
 
Configuration – you can specify the config that is used to process .html files during import. The default 
config name for current file format is: HTML. 
 
To edit selected configuration click Edit HTML Import Configuration button. 
The Description box contains description of selected config. 

Import Options XML files  
When you select Xml File (.xml) item in Formats list, XML configuration tab is displayed. 

 
 
Configuration – you can specify the config that is used to process .xml files during import.  
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Import Options Odt files  

 
Configuration – you can specify the config that is used to process .odt files during import.  

Options Import Text files  
There are no options available for text files when preparing for translation.  
Note that text files (*.txt) must have Unicode encoding to avoid problems with national characters. 
You can convert files encoding with: Encoding Conversion Utility 

Options Import Custom files  
There are no options available for custom files when preparing for translation.  
Note that text files (*.txt) must have Unicode encoding to avoid problems with national characters. 

Import Options .Xlsx files  
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Xml Import Config Editor  

 
Xml import Config window 
 
Elements List Grid contains information about all elements for Ms Word Xml file format. 
 
Element properties: 
1. Name – name of the element. Example element (.xml file fragment): element name is highlighted: 
<w:basedOn w:val="Solutionbullet"/> 
 
2. Element Description – comment that you can add for current element, useful when modifying import 
settings manually. 
 
3. Translatable – set if current element is to be considered translatable.  
Available values:  
- Not Translatable  – element will not be translated,  
- Translatable  - element will be translated,  
- Neutral  – inherits setting from previous/parent element,  
- NotTrans => Child  – element not translatable and all child elements will not be translated as well. 
- Format Tag  – element is a format tag, e.g. <b>,<i>,<u>, it is encapsulated with format tag delimiters («») 
to «<b>»,«<i>»,«<u>» 
 
4. Attributes – defines if current element attributes should be translated,  
Available values:  
- All  – all attributes will be translated (settings in attributes grid are not applicable),  
- None - none of the attributes will be translated (settings in attributes grid are not applicable),  
- ByConfig  – decided individually for each attribute, by Translatable  setting value for each attribute in 
attributes grid. 
 
5. Segment –  defines if current text in element should be considered as separate segment. Available 
values:  
Yes – segment delimiter placed,  
No – segment delimiter not placed,  
Neutral  – setting value is inherited from previous/parent element. 
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6. Stream – defines if current element is part of main document text stream. There are elements that are 
stand alone text units and should be translated separately, for example: comments, footnotes, endnotes, 
header, footer, text frames. Available values:  
- Normal  – element is part of main document text stream,  
- Beginning  – element is stand alone unit and should be placed before main text stream,  
- End - element is stand alone unit and should be placed at the end of the document (after main text 
stream). 
 

To add new element to import config click New  button on the Element List  toolbar. 
To delete element  from current config click Delete  button on the Element List  toolbar. 
 
Attributes list toolbar: 

1. Name – attribute name. Example w:style element: <w:style w:type="character" w:styleId="Test1"> 
presented element w:style has two attributes (attributes names highlighted). 

2. Attribute Description  – description of the attribute, 

3. Translatable – decides if attribute is translatable (option is valid only if current element Attributes 
setting is set to ByConfig ). 

 
Hint: To enable all defined configurations editing select Utils > Load All Configs. This applies to 
Professional and Enterprise editions of AidTrans Studio. 

Export Files  

To export translated files for current project select File > Export Translated , or click   button on main 
application toolbar, then Export Files  window pops up. 
  
The export function creates translated file in the export folder of current project based on translation 
performed in Translation Editor of AidTrans Studio. 
 

 
Export files window 
To perform export: 

1) Mark checkbox in Include  column for files that you wish to export. 
2) Click Start  button. 
3) If export is successful, button View Log  will be disabled. If any errors, warnings or messages 

occur, click View Log  button to see log details. 
 

To include all files for export in current project click  button on toolbar over the file list grid. 

To exclude all files from export files list click  button. Note that files will not be deleted from 
the list, only Include  column value will be set to false (unchecked). 
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To explore Export Folder click  button. 
 
To open folder that contains particular file:  
1) Click the row that contains file information,  
2) Click Open Export Folder button, new explorer window pops up with folder that contains selected file 
active. 
 
Export grid filter files  
 
You can filter files for the project by two major criteria: Target language and File Type. 
By default all files in project are displayed in files grid. 
 
For instance, if you wish to display only file translated into German language select German  in target 

language combo: . 
 
To filter data by File Type select one of available values in File Type  combo. 
 
Hint: You can also sort file list by each column value by clicking the column header. 
 
If no errors occur during export process, no log file is available. 
 

 

Export Options  
Overwrite if file already exists in export folder 
If this option is checked, files that already exist in export folder are overwritten with new ones. 
 
Log File 
You can specify the log file path. The log file path is auto-generated by AidTrans Studio by default, so 
selecting log file path is optional. 

Tag types in .ats files  

AidTrans Studio delimiting characters by tag type: 
 
Character   Description 

�  Segment tag open character 
�  Segment tag close character 

‹ Object tag open character 

› Object tag close character 

« Format tag open character 

» Format tag close character 

�  Placeable tag open character 
�  Placeable tag close character 

 

Object tags  

Object tags define .ats file structure they can never be included in segment text. You can also call this tag 
“external” as they occur outside the segments.  

In each .ats files there is an object tag that opens the file: ‹File_ID="….›  and one that closes the file: 
‹/File_ID….› 
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Format Tags  

Format tags usually represent text format information that is why they are called format tags. They usually 
occur inside segment body.  

Format tag sample: «11» 

Placeables Tags  
Expressions recognized as non translatables based on user defined configuration are enclosed within �  
and � characters.  
 
To configure expressions that should be marked as Placeables select Tools > Placeables config from 
AidTrans Studio main menu. 
 
Read more about how Placables configuration 

Segment Tags  
Segment Tags split file body into segments. Segment is a basic translation unit in translation editor.  
Each segment starts witch open segment tag: ��  
Each segment ends with close segment tags: � {segment number}{segment status character}�  
 
Segment statuses: 
Status name Status character 
Not translated “_” 
Fuzzy “±” 
100 % Matches “•” 
Internal repetition “°” 
Pending/Doubtful “?” 
Locked “� ” 
 

Tags Verification  

Before files export it is necessary to verify tags within translated file to make sure no tags have been 
modified during the translation process. 
  
To verify tags select: Tools > Tags Verification  
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Tags Verifier main window 
  
Columns in tag verifier main grid: 

-          File Name: File name and path, 
-          Include: Include file in check process, only file with value checked will be verified, 
-          Done: Set to true when tag verification is completed, value cannot be modified by user, 
-          Errors: Number of errors found in the file, 
-          Warnings: Number of warnings in the file. 

  

To verify tags for all files in project click  button and then click Start button. 
  
Errors/Warnings in File 
 
If there is a problem with tags in file, the number of errors or warnings will be greater then 0.  
  

To view details for a file: select row in grid, then click  button or just double click 
appropriate row in grid. Errors/Warnings in File  window pops up. 
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Errors/Warnings in File 
  
Error list for current file is displayed in grid on the left. 
 
Errors/Warnings in File  window  
 
Description box – contains information about current problem. 
Source text – source text for current tags problem.  
Current Target text – target text for current tags problem. 
Corrected Target Text – unit to edit the text so the tag structure is identical with the text from source text 
box. 

Correct tag error  
To correct tag error:  

1)     Select item on error list so that error details are presented on Error Details  panel. 
2)     Correct problem in Corrected Target Text  box. You need to edit text in Corrected Target Text  

box so tags in this box are adequate to tags in Source Text  box. 

3)     Click  button to replace text fragment in target file with the corrected one. 

4)     After correcting all the errors for file click  or OK button to save changes to file. Until you 
click Save file button, you can withdraw all the changes if you click Cancel  button. When changes 
are saved to file, you cannot undo them using Tag Verifier. 

 

Note: You can see more contexts for current tag error if you click  button. Text fragments in 
scope (both in source and translation files) are highlighted. 
 

4) Click Re-Verify File  button  to verify if your corrections have been successful. 
Updated error list will be displayed in grid on the left. If all errors have been corrected, the list will 
contain no elements. 

Sample Tag Errors  
Sample tag errors for three main tag categories: Object Tag, Segment Tag, Internal/Format Tag. 
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Object Tag sample errors  
 
  Source Text  Target Text  Description  
01 ��  ReadMe� 0_�  ‹<HEAD>› 

‹<TITLE>› 
��  Configuring «<b>»Internet 
Protocol «</b>»version 
X� 1_� ‹</TITLE>› 
  

��  ReadMe� 0_�  ‹<HEAD>› 
��  Configuring «<b>»Internet 
Protocol «</b>»version 
X� 1_� ‹</TITLE>› 
  

Object tag: ‹<TITLE>› was 
removed in translation.   
  

02 ��  ReadMe� 0_�  ‹<HEAD>› 
‹<TITLE>› 
��  Configuring «<b>»Internet 
Protocol «</b>»version 
X� 1_� ‹</TITLE>› 
  

��  ReadMe� 0_�  ‹<HEAD>› 
 ‹<TITLE>›‹<TITLE>› 
��  Configuring «<b>»Internet 
Protocol «</b>»version 
X� 1_� ‹</TITLE>› 
  

Object tag: ‹<TITLE>› was added 
to the translation. 

03 ��  ReadMe� 0_�  ‹<HEAD>› 
‹<TITLE>› 
��  Configuring «<b>»Internet 
Protocol «</b>»version 
X� 1_� ‹</TITLE>› 
  

��  ReadMe� 0_�  ‹<HEAD>› 
 <TITLE>› 
��  Configuring «<b>»Internet 
Protocol «</b>»version 
X� 1_� ‹</TITLE>› 
  

Object tag open char (“‹“) was 
removed from object tag: 
‹<TITLE>› 
  

        
04 ��  ReadMe� 0_�  ‹<HEAD>› 

‹<TITLE>› 
��  Configuring «<b>»Internet 
Protocol «</b>»version 
X� 1_� ‹</TITLE>› 
  

��  ReadMe� 0_�  ‹<HEAD>› 
 ‹<TITLES>› 
��  Configuring «<b>»Internet 
Protocol «</b>»version 
X� 1_� ‹</TITLE>› 
  

Object tag: ‹<TITLE>› was 
changed to ‹<TITLES>› in the 
translation document.  

05 ��  ReadMe� 0_�  ‹<HEAD>› 
‹<TITLE>› 
��  Configuring «<b>»Internet 
Protocol «</b>»version 
X� 1_� ‹</TITLE>› 
  

��  ReadMe� 0_�  ‹<TITLE>› 
‹<HEAD>› 
��  Configuring «<b>»Internet 
Protocol «</b>»version 
X� 1_� ‹</TITLE>› 
  

The sequence of object tags: 
‹<HEAD>› and ‹<TITLE>› was 
changed in translation. 
  

    
 

Segment Tag sample errors  
 
  Source Text  Target Text  Description  
  ��  ReadMe� 0_�  

‹<HEAD>› 
‹<TITLE>› 
��  Configuring «<b>»Internet 
Protocol «</b>»version 
X� 1_� ‹</TITLE>› 
  

��  ReadMe ‹<HEAD>› 
‹<TITLE>› 
 ��  Configuring «<b>»Internet 
Protocol «</b>»version 
X� 1_� ‹</TITLE>› 
  

Segment tag: � 0_�  was removed 
in translation. 

  ��  ReadMe� 0_�  
‹<HEAD>› 
‹<TITLE>› 
��  Configuring «<b>»Internet 
Protocol «</b>»version 
X� 1_� ‹</TITLE>› 
  

��  ReadMe� 0_�  ‹<HEAD>› 
 ‹<TITLE>› 
��  Configuring «<b>»Internet 
Protocol «</b>»version 
X��� 1_� ‹</TITLE>› 
  

Segment tag: ��  was added to the 
translation. 

  ��  ReadMe� 0_�  
‹<HEAD>› 
‹<TITLE>› 
��  Configuring «<b>»Internet 
Protocol «</b>»version 
X� 1_� ‹</TITLE>› 

��  ReadMe� 0_ ‹<HEAD>› 
 ‹<TITLE>› 
��  Configuring «<b>»Internet 
Protocol «</b>»version 
X� 1_� ‹</TITLE>› 
  

Segment tag close char (“� “) was 
removed from segment tag: � 0_�  
  

        

 

Internal/Format Tag sample errors  
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  Source Text  Target Text  Description  
  ��  Configuring «<b>»Internet 

Protocol «</b>»version 
X� 1_�  

�� Translation  Internet Protocol 
«</b>» goes here X� 1_�  

Internal Tag: «<b>» was removed in 
translation. 

  ��  Configuring «<b>»Internet 
Protocol «</b>»version 
«<u>»X«</u>»� 1_�  

�� Translation  «<b>»Internet 
Protocol «</b>» goes here 
X� 1_�  

Internal Tags:  «<u>» «</u>»   were 
removed in translation. 

  ��  Configuring «<b>»Internet 
Protocol «</b>»version 
X� 1_�  

�� Translation  
«<b>»«<b>»Internet Protocol 
«</b>» goes here X� 1_�  

Internal Tag: «<b>» was added to 
translation. 

  ��  Configuring «<b>»Internet 
Protocol «</b>»version 
X� 1_�  

�� Translation «<b> Internet 
Protocol «</b>» goes here 
X� 1_�  

Close character: “»“ of the internal tag: 
«<b>»  was removed so tag was 
damaged. 

  ��  Configuring «<b>»Internet 
Protocol «</b>»version 
X� 1_�  

�� Translation «<b> Internet 
Protocol </b>» goes here X� 1_�  

1) Close character: “»“of the internal 
tag: «<b>» was removed so tag was 
damaged. 
2) Open character: “« “of the internal 
tag: «</b>»  was removed so tag was 
damaged. 

  ��  Configuring «<b>»Internet 
Protocol «</b>»version 
X� 1_�  

�� Translation «<u>» Internet 
Protocol «</u>» goes here 
X� 1_�  

Internal tag content:  «<b>» was 
changed to: «<u>», «</b>»was 
changed to:  «</u>». 

  ��  Configuring «<b>»Internet 
Protocol «</b>»version 
«<u>»X«</u>»� 1_�  

�� Translation  «</b>»Internet 
Protocol «<b>» goes here 
«<u>»X«</u>»� 1_�  

Internal tag: «</b>» put before tag: 
«<b>» 
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Projects  

Project Folder Structure  
<AidTrans Studio Folder><Projects><Project Folder> 
  
  
Sample: 

 
  
__Temp 
Temporary folder 
  
App_files  
AidTrans Studio auxiliary files. If you create a batch file, .ats files for each file that batch includes will be 
stored in App_files\_batched_files_\ folder.   
  
Export  
The default folder for target translated files after the translation process. 
  
Import  
The default folder for source files to be prepared for translation. 
  
Translation  
The default folder for translation files (*.lngcode.ats, e.g. eng.ats ). If file to translate is taken from sub folder 
of import folder, then folder with the same name is created in translation folder. 
For instance, if you import file from \import\help\ , files from this folder will placed by AidTrans Studio in 
\translation\help  folder.  
 
Note that batch files created by AidTrans Studio during import are always placed in Translation folder 
without creating any subfolder. 
 
TranslationSend 
Optional folder, it is created only if you use Send Translation feature. 
 
The TranslationSend file is a zip file that contains all the .ats files from Translation  folder of current 
project. In most cases the TranslationSend file is created in order to send the translated files to the client. 
The default folder for send translation  files is not created by default when new project is created, but it 
appears when send translation file is created. 

Project Settings Edit  
To edit project settings select Project > Edit current project. 
  
Project Main Data 
 
Project Name – text label to identify project. 
Description – text description. 
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Project Folder – path to project root folder where all project files are stored. The default project folder path 
is: <AidTrans Studio main folder>\Projects\<Project Name>  
 
Project Languages: source and target languages for the project, these values are set when project is 
created. It is not possible to modify source and target language once the project is created. 
 
Translation memory - select Tm to be used in project. Note that Tm must have the same source and target 
language as project. 

Create New Project   
To create a new project you need to perform the following activities. 

1. Run AidTrans Studio, 

2. Select Project > New Project  or click the   (New Project) button on the toolbar, 
  

3. The Edit Project dialog window appears, 
  

 
 Main Project data tab is selected 
 
Hint: You can save most common source and target languages as default ones. To save currently selected source 

language as default source language click Save as Default Source  button. Next time when creating new project, 
these languages will be selected automatically. 

 
On Main Data  tab: 

a)     enter project name, 
b)     description (optional), 
c)     select source and target language for the project, 
d)     client and project subject selection (optional).   

  
4.  Click Translation Memory  tab and Select Project translation memory database. 

 
For each project you can use two translation memory databases. 

�  Project tm – all new segments added by translation editor are stored in this database. 
�  Reference tm – read-only tm database, used as reference. It is not to be modified from translation 

editor. 
Available options: 

�  Use network Db as Project Tm  - when checked, disables local db selection and enables network 
db as project tm. 

�  Use network Db as Reference Tm  - when checked, disables local db selection and enables 
network db as reference tm. 
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Translation memory selection tab. 
  
5.  Open local tm database (.atm file): 

�  click  button, when browse dialog window pops up, browse to file and click Open button, 
�  click New Tm button to create new tm database file. 

 
 
If you click Save as Default Project/Reference Tm  button, each time you create a new project (for current 
source and target language defined in current project in Main Data  tab)  current tm will be selected for new 
project. It is very useful as there is no need to specify tm each time you need to create project. 
 

6.  Click Terminology Database  tab, and Select Project terminology database. 

 
Terminology Database selection tab 
 
If you click Save as Default Project/Reference Tdb  button, each time you create a new project (for 
current source and target language defined in current project in Main Data tab)  current tdb will be selected 
for new project. It is very useful as there is no need to specify tdb each time you need to create project.  
 

7. Optional: Segmentation and Placeables configuration selection. See Segmentation guide for more 
info. 

8. Optional: Placeables Config selection, see Placeables section for more details.  
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Project Load  
To load project select Projects > Load Project , select project to load then click OK. Project that you 
selected becomes active project so you can edit its settings by selecting Project > Edit Current Project. 

Application Options  

Application options allow you to customize AidTrans studio to meet your individual preferences. To edit 

AidTrans Studio options select Tools > Options  on the menu or click   button on the application toolbar. 
 

 
 Application options window 

Options Automation  
It configures automated activities performed by AidTrans Studio translation editor when active segment is 
changed. 

Auto search tm entries  
When segment is selected (e.g. when you navigate to segment by Next Segment  button click), translation 
memory matches search is performed and results are loaded into Tm matches  window. The recommended 
option value is unchecked (false) as it is more intuitive to call tm matches search on user’s request. 

Auto search tdb matches   
When segment is selected, Tdb matches search is performed. The recommended option value is 
unchecked (false).   

Auto send translated segment into Tm  
When the option is checked, when segment status is changed to translated, current project tm is updated 
with segment source and target text. The recommended option value is unchecked (false). 
If option Synchronize View  is disabled, this option is not applicable.  
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Options Tm  
Configures translation memory usage from Translation editor  window. 

Min hit rate for fuzzy matches  
This is the threshold value for tm matches lookup. When match value is below specified value, it is not 
presented in tm matches window of the translation editor. For example, when you set option value to 80 % 
and tm database contains match with value 78 %, it is not considered as a valid fuzzy match. The 
recommended value is 75. 
This option applies to tm lookup from translation editor. 

Maximum number of hits  
Maximum number of matches to retrieve from tm matches lookup. 

Options Tdb  
Configures terminology database usage from translation editor environment. 

Minimum priority of tdb entries to display   
This option is valid only if current tdb database has Priority  column. Range of available values is from 0-10. 
Only tdb entries with priority column value equal to or over specified value will be displayed in tdb matches 
window of the translation editor. 
  
Value 0 disables tdb entries filtering by Priority value, it is the default setting value. 
 
Note: Do not change this setting value if you do not have tdb database with priority column. Then Tdb 
matches will be filtered out (based on priority value) by database engine, and no matches will be displayed! 
 
If Terminology database does not contain Priority  column, option value does not influence terminology 
lookup process. 
 
Sample option usage: 
You receive from your client a glossary for project with instruction that it is top priority reference. You import 
the glossary and set priority column value to 10. So the results from the glossary will display first in matches 
list and they will never be filtered out. At the same time you can use your standard terminology databases. 

Options Layout   
AidTrans Studio options that apply to translation editor layout. 

Synchronize view  
If checked, when segment is selected in source window, it is automatically selected in target window. 
Otherwise you can select other segments in source and target windows. 
Note that when this option is enabled, it is not possible to use automated translation memory update.  
Recommended value is unchecked (false). 

Tm matches window visible  
If checked=> tm matches window in translation editor is visible, otherwise it is hidden and no tm matches 
are displayed even if found. 
Recommended value is checked (true). 

Tdb matches window visible  
If checked=> tdb matches window in translation editor is visible, otherwise it is hidden and no tdb matches 
are displayed even if found. 
Recommended value is checked (true). 
  

Segment attributes window visible  
If checked, additional segment attributes (user modified, date modified, comment) window is visible.  
Recommended value is checked (true). 

Display each Segment on new line  
If checked, each segment in .ats file is displayed on new line. This option is useful when working with e.g. 
software strings. 
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Horizontal Windows arrangement  
If selected source and target windows are arranged horizontally. Source text window is located over the 
target window. 

Vertical Windows arrangement  
If selected source and target windows are arranged vertically. Source window is located on the left while 
target window is located on the right. 

Options Auto propagation  
Auto propagation options within translation editor. 

Enable auto propagation   
Enables auto propagation within current file. If this option is enabled, each time segment status is changed 
to translated, any identical segments within current document get the same translation as current segment.  
Auto propagation is especially useful when translating technical materials with large number of redundant 
segments. 
 
Default value is unchecked (false). 

Options Pretranslation  
Options for pretranslation process. 

Minimum match value  
This is the threshold value for tm matches lookup during preparing file for translation. This option applies to 
tm lookup during pretranslation. 
  

Put matches into target document threshold  
Matches with value equal/over specified threshold value will be copied into the target document. 
Recommended value is 100%. 
  

Tm matches not inserted if variant exists  
If more then one match is found (with the same hit rate) during pretranslation, none will be put into target 
document. This allows user to decide which match is more appropriate when translating document with 
translation editor.  

Options Editor  

Source Document Read Only  
If checked, then it is not possible to modify text in source window of translation editor.  

Exact matches considered translatable   
Exact matches segments are considered translatable. While navigating to next/previous translatable 
segments, these segments are included. If checked, exact matches segments are skipped while navigating 
to translatable segment. 

Spell Check mode  
It is possible to use Microsoft Word to perform spell check on *.ats files. 
 
AidTrans Studio built-in speller check is not yet available. 

Options Tags view   

Disable font/color settings   
If checked, all fonts and colors settings are disabled and applications defaults are enabled. Recommended 
value is false, however it should be checked when working with large files to improve performance of 
translation editor. 

Translatable text font settings  
It applies to the segment source/target text. 
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Object, Segment tags font settings  
It applies to object and segment tags. 
  

Format tags font settings  
It applies to format (internal) tags and placeables. 
  

Object tags view mode  
Full tag view mode: Whole tag is displayed. 
Only first and last char: Only last and first char of tag is displayed, the rest is hidden. 
  

Format tags view mode  
Full tag view mode: Whole tag is displayed. 
Only first and last char: Only last and first char of tag is displayed, rest is hidden. 
  

Tags protection  
Use the Protection options to define tag protection settings. Tags protection options define which tag types 
will be read-only. AidTrans Studio can protect tags so that you can avoid accidental deletion. 
 
Caution: Do not modify these settings unless you ar e an advanced user and you know what you are 
doing.  

Object tags read only  
If checked, object tags are protected against modification within the translation editor. Recommended value 
is checked (true). 

Format tags read only  
If checked, format tags are protected against modification within the translation editor. Recommended value 
is unchecked (false). 
  

Segment tags read only  
If checked, segment tags are protected against modification within the translation editor. Recommended 
value is checked (true). 

Options Tm Server  
Tm server settings are not present in AidTrans Studio Basic Edition as it does not support network 
translation memory databases. 
 

Tm Server Connection Settings  
You can specify Tm server that AidTrans studio is connected to.   
 
Click Test Tm Server Connection to verify if the connection is properly configured. 

Tdb Server Connection Settings  
You can specify Tdb server that AidTrans studio is connected to.   
 
Click Test Tdb Server Connection to verify if the connection is properly configured. 

Translation Memory Manager  

To manage tm database you need first to start Translation Memory Manager, which is a part of AidTrans 
studio. To start tm manager select Tm/Tdb > Tm Manager  in the main menu of AidTrans Studio.  
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Translation Memory Manager main window. 
 
Translation memory manager  user interface: 
 

�  Main menu and toolbars area (blue frame on screen above), 
�  Data grid that contains currently opened translation memory database (red frame), you can select 

columns that are displayed and apply sort on each column, 
�  Details panel - note that details panel layout depends on Translation Memory manager options 

(green frame), 
�  Status bar that displays currently opened database name (below details panel). 

 
 
Hint: In data grid you can apply sorting for any column, you just need to click column header. 
 

 
 

Sort ascending applied to TextSrc 
column 

(sort symbol highlighted with red 
frame). 

 
 
It is possible to edit Tm data both in grid and details panel. 

Translation Memory manager main menu  
From translation memory database manager main menu you can run all the data maintenance functions for 
currently opened database. You can also start import/export functions as well as add new entries. 
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Translation memory manager menu File  
 Item Description 

 New Creates new database. 

 Open Database Opens existing local database. 

 Open Project Tm  

- Project Tm Opens translation memory database defined as project database 
(updatable) in project settings. 

- Reference Tm Opens translation memory database defined as reference 
database (non updatable) in project settings. 

 Open Network Tm Runs Network Tm Selection window. 

 Save Saves changes to currently opened database. 

 Export Tm Database Runs export window. 

 Export Tm filtered Runs export with current filter applied. The feature exports only 
data displayed in grid after filter is applied. 

 Import Data Runs Import data window. 

 Exit Closes current window. 

   
 

Translation memory manager menu Edit    
 
 Item Description 

 
Undo Undo latest operation in currently active box. 

 Copy Copies selected text to clipboard. 

 Paste Pastes text from clipboard. 

 Delete row Deletes currently selected rows in data grid. Data once deleted 
from grid cannot be restored, so use this function carefully. 

 Find Finds specified text in data grid. 

 Replace Runs replace window. 

   
 

Translation memory manager menu View   
 
 Item Description 

 Filter Settings Runs Filter settings window. 
 Restore Default View 

Settings 
Restores default view settings for details panel, only source text 
and target text will be displayed.  

   

Translation memory manager menu Tools   
 Item Description 

 Options Runs Translation memory manager options edit window. 

 Tm database settings Runs current database settings window. 
 Add new Entry Runs Add new segment window - you need to edit only 

source and target text. 
 Add New Entry (Advanced 

Mode) 
Runs Add new segment window - you can edit source and target 
text and all the properties. 

 Remove rows with source 
and translation redundant 

Removes rows where source text and target text are identical.  

 Update Words Number 
Column 

Updates Words Number column value for each row in currently 
opened translation memory database. 

   
 

Translation memory manager menu Help  
 
 Item Description 
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 About Displays information about Translation memory manager version. 
 Help Content Displays help content for Translation memory manager. 
   

 

Translation memory manager main toolbar  
Icon  Item  Description 

 New Database Creates new database. 

 Open Database Opens a database. 

 
Open Database for Current 
Project 

Opens project Tm or reference Tm database specified for current 
project (project that is currently active in AidTrans Studio). 

 Close Current Database Closes currently opened database. 

 Import Data Imports data into currently opened database. 

 Export Data Exports data from currently opened database. 

 Database Settings  

 Options Runs options edit window. 

 Save View Config Saves current view configuration (grid and details panel). 

 Load View Config Defaults In case of any problem with manual view settings, you can restore 
application defaults. 

   

 Find Runs find text window which can be used to search for text in 
currently opened database. 

 Update Updates Tm Data. 
   

 First Segment Navigates to the first segment. 

 Prev Segment Navigates to the previous segment. 
 Next Segment Navigates to the next segment. 

 Last Segment Navigates to the last segment. 

 
Reload Data Reloads current database data. 

 
Help Displays help content. 

   
   

 

Translation Memory Manager filter toolbar  
 

 
 
Icon  Item  Description  

 Filter Filter box displays currently selected/applied filter name. If no filter 
is selected/applied, Filter box is empty. 

 Apply Filter Applies selected filter to currently opened database.  
 Cancel Filter Cancels current filter.  
 Filter Settings Runs filter settings window. 
   

 

Create new Tm database  

To create new translation memory database select File > New , or click button  on the main translation 
memory manager toolbar. 
The New Translation Memory Database  window appears. 
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New Translation Memory Database window 

 
1.      Specify translation memory database name, 
2.      Select source and target language. To change source or target language, select desired 

value from available languages list. You can select any language that is supported by the 
Unicode encoding standard. 

3.      If you wish to use default database structure, click Create Db . If you wish to customize 
database structure, go to Database Columns  tab. 

 

 
 

 
Database Columns tab 
 
To find out more about columns maintenance, read section: Tm\Tdb Database columns edit 

Hint:  
If you wish the created database to serve as main database for selected source and target languages, 
click Set default Main Db name button. 
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Tm database Open  

To open tm database select File > Open Tm  from files menu or click the Open  button on the main 
application toolbar. 
 
Open Tm databases for current project 
 
To open tm for current project select File >  Open Project tm > Project Tm  or Reference Tm  or click 

  button on the toolbar and select project/reference tm.  
  
Close tm  

To close tm database select Close  item from files menu or click  button on the toolbar. 

Tm Database Settings  
Tm structure can be customized not only when creating Tm database, but at any moment, even if there is 
data already present in translation memory database. 

To edit database settings select Tools > Tm database settings  or click  button.  

Change Source Target\Language  
  

 
Tm Languages\locales select 
 
Source and target language can be set only when new tm database is created.  
  
To get Tm database with different languages and the same data: 

1)     Export all data from current Tm to an .xml format, 
2)     Create new tm with desired source and target language, 
3)     Import .xml data file created in step one. 
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Tm columns edit window 
 
To find out more about Translation memory database columns maintenance, read section: Tm\Tdb 
Database columns edit 
  
Mandatory columns list: ID, TextSrc, TextTgt. Note that mandatory columns cannot be deleted or edited. 

Default Tm Structure  
ID – unique identifier of the record, mandatory column. 
TextSrc  – source text, mandatory column. The column name that contains source text is always the same 
regardless of tm source language. It applies both to local and network tm databases. 
TextTgt  – target text, mandatory column. The column name that contains target text is always the same 
regardless of tm target language. It applies both to local and network tm databases. 
SourceStatus  - status of the segment send to database, value is automatically set when updating from 
translation editor. 
UserCreated  – name (windows profile login) of the user who created the row. 
DateCreated  – date and time when row was created. 
Project  – source project for the row. When updating Tm from translation editor, current project name is set. 
Subject  – subject for current row. When updating Tm from translation editor, subject defined for current 
project is set. 
WordsNumber  – number of words in current row source text, updated by AidTrans Studio tm/tdb engine, 
mandatory column. 
CharsNumber  – number of characters in current row source text, updated by AidTrans Studio tm/tdb 
engine, mandatory column. 
Priority – priority of current row. 

Terminology Database Manager  

To manage a tdb database you need first to start Terminology Database Manager which is a part of 
AidTrans studio. To start tdb manager select Tm/Tdb > Tdb Manager in the main AidTrans Studio window 

menu or click  button on application toolbar.  
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Terminology Database Manager main window. 
 
Terminology database manager user interface: 

�  Main menu and toolbars area (blue frame on screen above), 
�  Data grid that contains currently opened terminology database (red frame). You can select columns 

that are displayed and apply sort on each column, 
�  Details panel (green frame). Note that details panel layout depends on Terminology manager 

options, 
�  Status bar that displays currently opened database name (below details panel). 

 
Hint: In data grid you can apply sort using any column, you just need to click column header. 
 

 
 

Sort ascending applied to TextSrc 
column 

(sort symbol highlighted with red 
frame). 

 
 
It is possible to edit terminology data both in grid and details panel. 

Terminology database manager main menu  
From terminology database manager main menu you can run all the data maintenance functions for 
currently opened database. You can also start import/export functions as well as add new entries. 

Terminology database manager menu File  
 
 Item Description 
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 New Creates new database. 

 Open Database Opens local database. 

 Open Project Tdb  

- Project Tdb Opens terminology database defined as project database 
(updatable) in project settings. 

- Reference Tdb Opens terminology database defined as reference database (non 
updatable) in project settings. 

 Open Network Tdb Runs Network Tdb Selection window. 

 Save Saves changes to currently opened database. 

 Export Tdb Database Runs export window. 

 Export Tdb filtered Runs export with current filter applied. The feature exports only 
data displayed in grid after filter is applied. 

 Import Data Runs Import data window. 

 Exit Closes current window. 

   
 

Terminology database manager menu Edit    
 
 Item Description 

 
Undo Undo latest operation in currently active box. 

 Copy Copies selected text to clipboard. 

 Paste Pastes text from clipboard. 

 Delete row Deletes currently selected rows in data grid. Data once deleted 
from grid cannot be restored so use this function carefully. 

 Find Finds specified text in data grid. 

 Replace Runs replace window. 

   
 

Terminology database manager menu View  
 
 Item Description 

 Filter Settings Runs Filter Settings window. 
 Restore Default View 

Settings 
Restores default view settings for details panel, only source text 
and target text will be displayed. 

   

Terminology database manager menu Tools  
 
 Item Description 

 Options Runs Terminology database manager options edit window. 

 Tdb database settings Runs current database settings window. 
 Add new Entry Runs Add new segment window - you need to edit only 

source and target text. 
 Add New Entry (Advanced 

Mode) 
Runs Add new segment window - you can edit source and target 
text and all the properties. 

 Remove rows with source 
and translation redundant 

Removes rows where source text and target text are identical.  

 Update Words Number 
Column 

Updates Words Number column value for each row in currently 
opened Terminology database. 

   
 

Terminology database manager menu Help  
 
 Item Description 

 About Displays information about Terminology database manager 
version. 
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 Help Content Displays help content for Terminology database manager. 
   

 

Terminology database manager main toolbar  
 
Icon  Item  Description 

 New Database Creates new database. 

 Open Database Opens new database. 

 
Open Database for Current 
Project 

Opens project Tm or reference Tm database specified for current 
project (project that is currently active in AidTrans Studio). 

 Close Current Database Closes currently opened database. 

 Import Data Imports data into currently opened database. 

 Export Data Exports data from currently opened database. 

 Database Settings  

 Options Runs options edit window. 

 Save View Config Saves current view configuration (grid and details panel). 

 Load View Config Defaults In case of any problem with manual view settings, you can restore 
application defaults.  

   

 Find Runs find text window which can be used to search for text in 
currently opened database. 

 Update Updates Tm Data. 
   

 First Segment Navigates to the first segment. 

 Prev Segment Navigates to the previous segment. 
 Next Segment Navigates to the next segment. 

 Last Segment Navigates to the last segment. 

 
Reload Data Reloads current database data. 

 
Help Displays help content. 

   
   

 

Translation Memory Manager filter toolbar  
 

 
 
Icon  Item  Description  

 Filter Filter box displays currently selected/applied filter name. If no filter 
is selected/applied, Filter box is empty. 

 Apply Filter Applies selected filter to currently opened database.  
 Cancel Filter Cancels current filter.  
 Filter Settings Runs filter settings window. 
   

 

Terminology database Manager main toolbar:  
 

 
 
Icon  Item Description 

 
New Database Creates new database. 

 Open Database Opens new database. 

 Open Database for Current 
Project 

Opens project Tm or reference Tm database specified for current 
project (project that is currently active in AidTrans Studio). 
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To open project database 
select Project Db  item, 

to open reference database 
select Reference Db  
item.  

 Close Current Database Closes currently opened database. 

 Import Data Imports data into currently opened database. 

 Export Data Exports data from currently opened database. 

 Database Settings  

 Options Runs options edit window. 

 Save View Config Saves current view configuration (grid and details panel). 

 Load View Config Defaults In case of any problem with manual view settings, you can restore 
application defaults. 

   

 Find Runs find text window which can be used to search for text in 
currently opened database. 

 Update Updates Tm Data. 
   

 First Segment Navigates to the first segment. 

 Previous Segment Navigates to the previous segment. 
 Next Segment Navigates to the next segment. 

 Last Segment Navigates to the last segment. 

 
Reload Data Reloads current database data. 

 
Help Displays help content. 

   
   

Tdb database Create new   

To create new tdb database select File > New  item from menu, or click  button on the main Terminology 
Database Manager toolbar. 
The New Tdb database  window appears. 

   
New Tdb database window. 
 
To create new terminology database: 

1.      Specify terminology database name, 
2.      Select source and target language. To change source or target language select desired 

value from available languages list. You can select any language that is supported by the 
Unicode encoding standard. 

3.    If you wish to use default database structure, click Create Db  button. If you wish to 
customize database structure, go to Database Columns  tab. 

 
To find out more about columns maintenance, read section: Tm\Tdb Database columns edit 
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Tdb database Open   

To open tdb database select File > Open  from files menu or click Open  button on the main toolbar. 
Then browse to .atd file you wish to open. 
 
  
Open Tdb databases for current project 
To open tdb for current project select File >  Open Project Tdb > Project Tdb  or Reference Tdb  or click 

  button on the toolbar and select project/reference tdb.  

Tdb Close   

To close Tm database select Files > Close  or click Close   button on the toolbar. 

Default Tdb Structure  
ID – unique identifier of the record, mandatory column. 
TextSrc  – source text, mandatory column. The column name that contains source term/expression is 
always the same regardless of tdb source language. It applies both to local and network tdb databases. 
TextTgt – target text, mandatory column. The column name that contains target term/expression is always 
the same regardless of tdb target language. It applies both to local and network tdb databases. 
SourceStatus  – status of the segment sent to database, value is automatically set when updating from 
translation editor. 
UserCreated  –name (windows profile login) of the user that created the row.  
DateCreated  – date and time when row was created. 
Project  – source project for the row. When updating Tm from translation editor, current project name is 
entered. 
Subject  – subject for current row. When updating Tm from translation editor, subject defined for current 
project is entered. 
WordsNumber  – number of words in current row source text updated by AidTrans Studio tm/tdb engine, 
mandatory column. 
CharsNumber  – number of characters in current row source text updated by AidTrans Studio tm/tdb 
engine, mandatory column. 
Priority – priority of current row. 

Tm\Tdb data management  

Tm\Tdb data Import  

To import data into Tm database select File > Import Data  item or click   button on the main toolbar of 
Tm\Tdb manager. 

Tm\Tdb data Import, formats supported:  
-          Ms Access (.mdb), 
-          Ms Excel (.xls), 
-          Xml (.xml), 
-          MultiTerm file (.txt),  (up. To 6.5), 
-          Trados Tmw (.txt) (up. To 6.5), 
-          Transit 2.7, Fortis file (.TheeLetterLangCode, e.g. .ENG, .POL), 
-          AidTrans Studio Edit files (.ats), 
-          TMX files (.tmx). 
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Import data into Tm window 

 
 To import data into tm database: 

1. Select import file format from available list, 
2. Specify import file path, (click Open button then browse for file), if you wish to open last folder 

browsed with tm manager, click Browse last selected folder  button. If left unchecked, browsing 
starts with last folder used.  

3. Select import format from available formats list. 
4. Set format specific options: 
-          Ms Access: Select table to import data from, 
-          Excel file: Select worksheet to import data from and specify if first row contains column names, 
-          Text Delimited: Specify if first row contains column names, Text Encoding, Column delimiter, Text 

qualifier, 
-          XML: Specify the source element to import data from, 
-          Transit 2.7, Fortis: Specify source and target language, encodings, project definition file, segment 

statuses list to include in import, 
-          AidTrans Studio edit files (*.ats): Select segment statuses list to include in import, source/target 

language, 
-          TMX (Translation Memory Exchange) files: Specify source and target column mapping and 

optionally attributes columns mapping, 
6. Go to the second tab and select column mapping. You can also enable option Allow values in 

columns manually  to be able to set some columns values manually. Set the Value (Manual)  box 
text to value that will be copied to each row imported into tm (to a column specified in Column 
name box), e.g. if you import data for medical project, you type in Column name  box value 
Subject  and in Value (Manual)  box type ‘medical’. So for each row imported, value in column 
subject will be set to ‘medical’. 

7. Optionally you can set import options. 
  
When segment with identical source and translation exists in the database: 

�  Overwrite: existing data is overwritten with imported row, 
�  Ignore: imported data is ignored, 
�  Add new anyway: new row is added. 
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Columns Mapping Tab 
 
Functions/Options available: 
 
- Allow user to set selected columns values manually : if option is checked, you can set any column 
values (the right pane). E.g. if you import TM for one project and you want value of ‘project’ column for all 
rows to be ‘RTJ23’, you need to set Column name  box to ‘project’ and Value (Manual)  box to value 
‘RTJ23’. 
1) Check option (pane on the right is enabled then), 
2) In the first combo box select ‘project’ column and type value ‘RTJ23’ in the combo box labeled Value 
(Manual) . 

 

Tm\Tdb Database settings  
This section applies to both translation memory and terminology databases. 
 
Database structure can be customized not only when creating database, but at any moment, even if there 
is some data present. 
 
To edit database settings: 

�  start Translation Memory Manager or Terminology Database Manager, 
�  open database you wish to edit. 

 

To edit terminology database settings select Tools > Tm database settings  or click  button in 
Translation Memory Manager.  
 

To edit terminology database settings select Tools > Tdb database settings  or click  button in 
Terminology Database Manager.  
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Languages locales  

�  Source language 
�  Target language 

Tm\Tdb Database columns edit  
This section applies to both translation memory and terminology databases structure maintenance. 
 

�  Maintain tm columns: you can add new columns, edit and delete existing ones. 

 
 Tm columns edit window. 
 
Add new column  
To add new column click New column , in pop up window type column name and optional description, and 
then select column type from the available list. 
  
Delete column  
To Delete column first select column in grid, then click Delete  column  button. 
  
Edit column details  
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To edit column details first select column in grid, then click Edit column specs , then in the pop up window 
you can edit column name, description and data type. 
  
Mandatory columns list: ID, TextSrc, TextTgt. Note that mandatory columns cannot be deleted or edited. 

Tm/Tdb Manager Options  
View Options  
  
Show details panel when row selected  
If checked, tm row details are visible in a frame at the bottom of main Tm manager window. 
  
Accept changes on details panel close  
If checked when details panel content is refreshed, changes to current row are accepted. If unchecked, 
changes to current row are rejected.  
 
Grid font settings  
You can set font attributes used in main tm manager grid.  

Tm/Tdb Manager Details panel config  
You can customize details panel to meet your individual preferences. You can set font properties, size and 
position as well as back color of each database column.  
Save column arrangement  

To save column arrangement click  button on the main toolbar. 
  
Find/Replace  
To find/replace any text in main grid select Edit > Find.  
  

Tm/Tdb Manager Rows Navigation  
  
Go to first row  

To go to the first row click  button on the main toolbar. 
  
Go to previous row  

To go to the previous row click  button on the main toolbar.  
  
Go to next row  

To go to the next row click  button on the main toolbar.  
  
Go to last row  

To go to the last row click  button on the main toolbar.  

Data Filtering in Tm/Tdb Manager   

Data filter toolbar provides features to filter data in current database. Note that data filtering functionality is 
common for translation memory and terminology databases. 

  
Filter toolbar 
  
Apply filter  
To apply filter: 

1)     Select filter from the available filters list, 

2)     Click Apply Selected Filter   button. 
  
Cancel filter (Display all data)  



 

AidTrans Studio Basic 2.0   Page 63 of 88 

To cancel filter and show all data click  Cancel Filter  button. 
  
Edit Filters  

To edit filters click Edit Filters  button or select Filter Settings  from view menu, then Filter Settings 
window pops up. 
  

 
Filter Settings, easy mode. 
  
Easy mode  
Click the Easy mode  tab on Filter settings window to work with filters in easy mode. Note that filters 
created in easy mode are only displayed on the Easy mode  tab, you cannot edit these filters in advanced 
mode. 
  
Create new filter in easy mode  
To create new filter in easy mode click New button and new filter is added to filters list. Then click the filter 
row and adjust filter properties: name, description and value. 
  
Add new filter condition  
To add new filter condition: select column name, operator and then value. For example, if you wish to select 
source or target segments starting with letter ‘a’, you need to (assuming database is from English into 
Polish): 
  

1)     select source column TextSrc ,  
2)     select operator Like , 
3)     in value box type a*, 
4)     select OR as link expression, 
5)     select second column TextTgt , 
6)     select operator Like , 
7)     in value box type d*. 
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Filter value edit. 

Test filter syntax  
To test filter syntax click Test syntax  button. If syntax is ok, message 'Filter syntax successfully tested!’ 
appears. Otherwise error message is displayed. 
  
Save filter value  
To save changes to the filter click Save button. To reject changes click Cancel  button.  
  
Delete filter  
To delete filter first select filter row on filter list grid, and then click Delete  button.  
 

 
Tm Filter Advanced mode. 
  
Advanced mode  
Click the Advanced mode tab on Filter settings window to work with filters in advanced mode. 
  
Create new filter in Advanced  mode  
To create new filter in advanced mode click New button and new filter is added to filters list. Then click the 
filter row and adjust filter properties: name, description and value. 
  
Edit Filter value in advanced mode  
In advanced mode you type filter expression in the box. You can see list of all available columns list in 
Column  box, and all available operators in Operators  box. To copy column/operator value to filter box, 

click Copy   button. 
  
Sample filter syntax: 
  
����������	���������	������
��	���������	�������  
  
Filter syntax should match pattern: <column name> <operator> <value> OR/AND <column name> 
<operator> <value> … 
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Note: you can use brackets to create more sophisticated multilevel filter expressions: 
(<column name> <operator> <value> OR/AND <column name> <operator> <value>) OR/AND (next 
expression). 

Test filter syntax  
To test filter syntax click Test syntax  button. If syntax is ok, message 'Filter syntax successfully tested!’ 
appears. Otherwise error message is displayed. 
 
Note: Filters are valid only for the databases that contain columns used to build filter value. If you create 
filter that uses ‘Project’ column, you cannot apply it to the database that does not contain this column.   
Add new entry to current database  
To add new entry to current database select Add new Entry  item from tools menu. New row dialog window 
will pop up, only mandatory columns need to be filled in (source and target value).   
 

 
Add new entry dialog window. 
Add new entry all fields  
To add new entry to current database select Add new Entry (Advanced mode)  item from tools menu. All 
databases will be presented to fill in, however, you can leave some fields blank.  
Remove redundant rows  
If you wish to remove duplicate rows from database (source and target redundant), select Remove rows 
with source and target redundant. 
Update words number column  
After manual editing of rows in database, it is recommended to run function that updates words number 
column, as this information is important for matches lookup. 
You do not need to run this function when importing data, as it is run as integral part of import process. 

Export data from Tm\Tdb Database  
To export data from current database select Export Data  from file menu, or click the Export  button. 
To export filtered data (with current filter applied) select Export data filtered  item from files menu. 
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Export Tm window. 
  
To export data from current database:  

1. Select export file format from available list, 
2. Specify export file path, 
3. Specify columns to include in export file by selecting items in grid on Select columns  tab, 
4. Optionally you can set export options. If you set option: Allow manual column values,  additional 

column in column list appears, and you can specify the constant value for all rows in exported data.  
 

 
5. Click Start Export  button. 

 
Supported export formats: 
1. Ms Excel file (.xls):  
To open exported file in Microsoft Excel, double click the file in Windows explorer or start Microsoft Excel, 
select File > Open , browse to exported file and click Open button in Open dialog window. 
 
2. Ms Excel delimited file (.csv): 
To open file in Micorosft Excel double click on the file in Windows explorer. File has Unicode encoding. 
 
3. Text delimited file (.txt): 
Some export file information: 

o Unicode Encoding,  
o Tab characters used as column separator, 
o No text qualifier is used (column values are not enclosed in “” characters).  
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4. Multiterm text file (*.txt), 
5. Trados Tmw text file, 
6. Tmx file. 

Segmentation  

Segmentation in AidTrans Studio is based on .Net Framework regular expressions. To know more about 
regular expressions syntax, read Regular Expressions Guide available to download in documentation 
section on AidTrans Soft website. 
 
Hint: You can test regular expressions that you wish to add to segmentation config using Regular 
Expression Test Utility. To run it, select: Utilities > Regular Expression  Test Utility . 
 
To run Segmentation settings window, select Tools  >Segmentation Config.  
  

 
 Segmentation configuration main window. 
 
Each row in Segmentation Config List grid is a separate segmentation configuration. 
 
Segmentation Config List grid columns: 

�  Config Name, name of segmentation configuration, 
�  Description, some additional information about current configuration. 

 
Active segmentation config name is displayed in highlighted row in Segmentation Config List  grid. 

Segmentation – Add new config  
To add new segmentation Config click New Config  button on top toolbar.  
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To create new segmentation Config based on existing one, select config and click Save Config As  button, 
and then type desired config name. Note that the config name must be unique.  

Segment on expressions:  
Segment delimiters are created for defined expressions matches. 

Segmentation Exceptions  
Regular expressions that define which split points should not be segment borders. 
 
Note that for each segmentation item you can put some comment (in description column), so it is easier to 
implement changes. If you change the segmentation item value, you can put the old value in description, so 
if there is any problem with new value, you can go back to the old one which you can copy from the 
description. 
  
Hint:  It is better to specify more segmentation expressions which are less general, than to create small 

number of general segmentation rules and many segmentation exceptions.  
 
 

Segmentation expressions: examples  
1) Segment expression:  
before Split after split   
\.\s+ [A-Z] It matches dot character ‘.’ followed by white space (one or more) and 

capital letter. 
 
The sample text fragment with segment match: 
 AidTrans Studio is a translation memory tool. <Split point match> It provides tools to manage both 
translation memory (tm) and terminology database (tdb), translation editor and a set of useful utilities for 
tasks related to translation process.  
The segment border is placed after white space character. 
2) Sample expression modified: 
  
before Split after split   
\.\s+[A-Z]   Whole expression is moved to the before split section. 
  
The sample text fragment with segment match: 
 AidTrans Studio is a translation memory tool. I<Split point match> t provides tools to manage both 
translation memory (tm) and terminology database (tdb), translation editor and a set of useful utilities for 
tasks related to translation process.  
The segment border is placed after letter ‘I’ that is matched by [A-Z] regular expression. 
  
3) Sample expression modified: 
  
before Split after split   
  \.\s+[A-Z] Whole expression is moved to the after split section. 
  
The sample text fragment, with segment match: 
 AidTrans Studio is a translation memory too<Split point match >. It provides tools to manage both 
translation memory (tm) and terminology database (tdb), translation editor and a set of useful utilities for 
tasks related to translation process.  
The segment border is placed before ‘.’ character as match for regular expression: ‘\.’ is located in the after 
split  section. 

Placeables  

What is placeable:  
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Placeable is the translation segment fragment which should not be translated. You can also call it non-
translatable. 
 
Usually these are: proper names, numbers, non translatable characters or expressions. See example 
below:  
Source text:  The MatrixExt sequence starts from 400 up to 600 with step 2.  
Translation:  MatrixExt <text> 400 <text> 600 <text> 2. 
There are three numbers: 400, 600 and 2, and proper name: MatrixExt that are not to be translated.  
 
Placeables management in AidTrans Studio gives you opportunity to decide which expressions should be 
marked as not for translation. In many translation system non-translatables are limited to numbers or 
acronyms, in AidTrans Studio you can define regular expressions, or text expressions that should be 
handled as non-translatables. 
  
Disable placeables   
How to turn off placeables processing when importing files for translation: select placeables configuration 
named ‘None’ on the Options  tab in Prepare file for translation  window. 
  
To run Placeables config edit window select Tools > Placeables config . 
  

 
Placeables configuration – main window. 
  
There are two placeables categories which you can define in AidTrans Studio: text patterns using regular 
expressions and text expressions. 

Placeables config management  
Add new placeables config.  
  
To add new placeables config click Add new  button on config List tab and the placeables edit window 
appears. Type config name and optionally description, language that config applies to, and subject. 
  
Delete placeables config.  
To delete selected placeables config click Delete button.  
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To save changes done to the placeables config click Update  button.  

Placeables Text files management  
Add new placeables text file  
  
To add new file containing text placeables, click Add new  button on the Placeables – text files tab. Select 
the file and then click OK.   
Note: File with text placeables must contain each placeable on separate line.  
 

 
Sample placeables text file (each placeable express ion in separate line). 
 
Delete placeables text file  
 
To delete placeables text file along with all its items, select file in the Placeables text files list grid and then 
click Delete button left to the grid. 

Placeables Regular Expressions Management  
Add new placeable regular expression.  
  
To add new placeable regular expression, click Add new  on placeable regular expression tab.  Then type 
placeable in value textbox, optionally you can put some description. 
  
Delete placeable regular expression  
Select item you wish to delete in the grid on the placeable regular expression tab, then click Delete. 

Translation Kit  

Translation Kit Idea  
It is a file which contains text for translation, reference materials (tm and tdb database) and settings. 
Translation companies often send translation jobs to freelance translators, and with AidTrans Studio you 
can simplify and automate translation job preparation process. 
 
 Translation Kit Advantages for Translation Company : 

�  You can specify settings of both project and AidTrans Studio application, you can precisely define if 
100 % matches should be processed or not, as well as set settings for tag protection and tm\tdb 
matching. 

�  Translation kit can be opened with AidTrans Studio basic edition. You do not need to persuade a 
translator to buy any tool, you just provide link to download AidTrans Studio Basic. Basic edition is 
not only for processing Translation kits, but it can also work with new files from two most popular 
text editions: Microsoft Word and OpenOffice Writer. This makes it easier for Translation Company 
to persuade a freelancer to use this translation memory program. 

�  Translation Kit is very easy to open and start translation (there is no need for .dtd files, there is no 
additional configuration that must be done by translator).  

�  Easy glossaries integration with terminology database (no more sending glossaries in Excel). 
 
Translation Kit Advantages for freelance translator : 

�  Setup for translation job is very easy, with translation kit open all the files, references and settings 
are there. 

�  Sending translated file is very easy, you use one command to create one zip file to send translation 
back to translation company. 
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Note: Only with AidTrans Studio Enterprise you can create Translation Kit, as Translation Kit Manager is a 
part of Enterprise edition. 

You can open Translation Kit file (.AtsTKit file) with any AidTrans Studio Edition. 

 

Translation Kit content  
Translation kit contains: 
- files for translation/proofreading files (.ats format), 
- translation memory database file (.atm), 
- terminology database file (.atd), 
- project settings (.xml file), 
- application options (.xml file, translation editor settings only).  

Translation Kit Manager  
With Translation Kit Manager you can create translation kits, edit their content and properties, and create 
Translation Kit file to send to translator. 
 

 
Translation Kit Manager window. 

Translation Kit – beginner translator’s guide  
 

How to browse terminology database content provided  in Translation Kit?  
Translation Kit must be opened (to open translation kit select File > Open Translation Kit File ). 
Translation Kit project must be loaded (select Project > Load Project ).  
 
To browse terminology database content provided with translation kit: 

1. Start Terminology database manager, select Tm/Tdb > Tdb Manager  or click  button on application 
toolbar in main AidTrans Studio window. 

2. In Terminology database manager select File > Open Project Tdb > Project Tdb  or click  button 
on toolbar and select Project Db  from dropdown menu. 
3. Terminology database content is displayed in Terminology database manager grid. 
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Is it possible to use my own Tm as a reference for Translation Kit translation?  
Yes, however, you need to have AidTrans Studio Professional edition. Translation Kit contains only one 
Translation memory database and terminology database, while in professional edition for each project you 
can define two tms and two tdbs. 
 
Once Translation Kit is opened you need to run Projects > Edit current Project , go to Translation Memory 
tab and select Reference TM database you wish to use. 

Appendix  

AidTrans Studio application folder structure   

 
Let us assume that AidTrans Studio installed folder is: C:\AidTransStudioBasic2 
List of subfolders in C:\AidTransStudioBasic2 folder: 
 
\Bin  - application binaries, 
\Config – application configuration files, like project definitions, import settings, segmentation and 
placeables data, templates, 
\Projects – all the project files are placed in this folder, it contains all the .ats files that are actually 
translated, as well as application auxiliary files. 
\TDB – folder contains terminology databases (.atd files), default folder for new terminology databases, 
\TM – folder contains translation memory databases (.atm files), default folder for new translation memory 
databases, 
\Temp – temporary data folder. 
 

 

Segment Status List  
List of statuses of segment in AidTrans Studio. 
 

Name  Short     Description  

 Not translated  “_”  NT The original status of a 
segment. 

 Fuzzy “±”  F 
There is fuzzy match in 
current translation 
memory database. 

 100 % Matches  “•”  E 
Segments which are 
100% matches from tm 
database. 

 Internal repetition  “°”  I 
Segment which occurs 
more than once in 
repetitions lookup scope. 

 Pending/Doubtful  “?”  D 

The segment is actually 
translated, but there are 
still some activities to 
finish translation.  

 Translated  “+”  T The segment is 
translated. 

 Proofread  „ � ”  P 
It is the final segment 
status in translation 
process. 

  Locked   „ � ”   L Segment is locked; it is 
not to be modified. 
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  AidTrans Studio Special Characters  
There are some special characters in AidTrans Studio translation files .ats: 
 
Value  Description 

�  Segment tag open character 

�  Segment tag close character 

‹ Object tag open character 

› Object tag close character 

« Format tag open character 

» Format tag close character 

�  Placeable open character 
�  Placeable close character 

 

 

XML/HTML Special characters  

 
                " " "&nbsp;" 
                "-" "&shy;" 
                """ "&quot;" 

            "&" "&amp;" 
            "!" "&iexcl;" 

            "¦" "&brvbar;" 
            "¨" "&uml;" 

            "—" "&macr;" 
            "´" "&acute;" 
            "¸" "&cedil;" 

            "?" "&iquest;" 
            "<" "&lt;" 
            ">" "&gt;" 

            "±" "&plusmn;" 
            "«" "&laquo;" 
            "»" "&raquo;" 
            "×" "&times;" 
            "÷" "&divide;" 
            "c" "&cent;" 

            "L" "&pound;" 
            "¤" "&curren;" 

            "Y" "&yen;" 
            "§" "&sect;" 
            "©" "&copy;" 
            "¬" "&not;" 
            "®" "&reg;" 
            "°" "&deg;" 

            "µ" "&micro;" 
            "¶" "&para;" 

            "•" "&middot;" 
            "� " "&euro;" 

            "1" "&frac14;" 
            "1" "&frac12;" 
            "3" "&frac34;" 

            "1" "&sup1;" 
            "2" "&sup2;" 
            "3" "&sup3;" 
            "Á" "&Aacute;" 
            "á" "&aacute;" 
            "Â" "&Acirc;" 
            "â" "&acirc;" 
            "A" "&Agrave;" 
            "a" "&agrave;" 
            "A" "&Aring;" 
            "a" ":&aring;" 
            "A" "&Atilde;" 
            "a" "&atilde;" 
            "Ä" "&Auml;" 
            "ä" "&auml;" 
            "a" "&ordf;" 
            "A" "&AElig;" 
            "a" "&aelig;" 
            "Ç" "&Ccedil;" 
            "ç" "&ccedil;" 
            "?" "&eth;" 
            "?" "&ETH;" 
            "É" "&Eacute;" 
            "é" "&eacute;" 
            "E" "&Ecirc;" 
            "e" "&ecirc;" 
            "E" "&Egrave;" 
            "e" "&egrave;" 
            "Ë" "&Euml;" 
            "ë" "&euml;" 
            "Í" "&Iacute;" 
            "í" "&iacute;" 
            "Î" "&Icirc;" 
            "î" "&icirc;" 

            "I" "&Igrave;" 
            "i" "&igrave;" 
            "I" "&Iuml;" 
            "i" "&iuml;" 
            "N" "&Ntilde;" 
            "n" "&ntilde;" 
            "Ó" "&Oacute;" 
            "ó" "&oacute;" 
            "Ô" "&Ocirc;" 
            "ô" "&ocirc;" 
            "O" "&Ograve;" 
            "o" "&ograve;" 
            "o" "&ordm;" 
            "O" "&Oslash;" 
            "o" "&oslash;" 
            "O" "&Otilde;" 
            "o" "&otilde;" 
            "Ö" "&Ouml;" 
            "ö" "&ouml;" 
            "ß" "&szlig;" 
            "?" "&THORN;" 
            "?" "&thorn;" 
            "Ú" "&Uacute;" 
            "ú" "&uacute;" 
            "U" "&Ucirc;" 
            "u " "&ucirc;" 
            "U" "&Ugrave;" 
            "u" "&ugrave;" 
            "Ü" "&Uuml;" 
            "ü" "&uuml;" 
            "Ý" "&Yacute;" 
            "ý" "&yacute;" 
            "y" "&yuml;" 

 

Encodings List supported  
The following table lists the encodings and their associated code pages. 

 
Code\Name Display Name Code Page  
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IBM864  Arabic (864)  864 
ASMO-708  Arabic (ASMO 708)  708 
DOS-720  Arabic (DOS)  720 
iso-8859-6  Arabic (ISO)  28596 
x-mac-arabic  Arabic (Mac)  10004 
windows-1256  Arabic (Windows)  1256 
ibm775  Baltic (DOS)  775 
iso-8859-4  Baltic (ISO)  28594 
windows-1257  Baltic (Windows)  1257 
ibm852  Central European (DOS)  852 
iso-8859-2  Central European (ISO)  28592 
x-mac-ce  Central European (Mac)  10029 
windows-1250  Central European (Windows)  1250 
EUC-CN  Chinese Simplified (EUC)  51936 
GB18030  Chinese Simplified (GB18030)  54936 
gb2312  Chinese Simplified (GB2312)  936 
x-cp20936  Chinese Simplified (GB2312-80)  20936 
hz-gb-2312  Chinese Simplified (HZ)  52936 
x-cp50227  Chinese Simplified (ISO-2022)  50227 
x-mac-chinesesimp  Chinese Simplified (Mac)  10008 
big5  Chinese Traditional (Big5)  950 
x-Chinese-CNS  Chinese Traditional (CNS)  20000 
x-Chinese-Eten  Chinese Traditional (Eten)  20002 
x-mac-chinesetrad  Chinese Traditional (Mac)  10002 
x-mac-croatian  Croatian (Mac)  10082 
cp866  Cyrillic (DOS)  866 
iso-8859-5  Cyrillic (ISO)  28595 
koi8-r  Cyrillic (KOI8-R)  20866 
koi8-u  Cyrillic (KOI8-U)  21866 
x-mac-cyrillic  Cyrillic (Mac)  10007 
windows-1251  Cyrillic (Windows)  1251 
iso-8859-13  Estonian (ISO)  28603 
x-Europa  Europa  29001 
IBM863  French Canadian (DOS)  863 
x-IA5-German  German (IA5)  20106 
ibm737  Greek (DOS)  737 
iso-8859-7  Greek (ISO)  28597 
x-mac-greek  Greek (Mac)  10006 
windows-1253  Greek (Windows)  1253 
ibm869  Greek, Modern (DOS)  869 
DOS-862  Hebrew (DOS)  862 
iso-8859-8-i  Hebrew (ISO-Logical)  38598 
iso-8859-8  Hebrew (ISO-Visual)  28598 
x-mac-hebrew  Hebrew (Mac)  10005 
windows-1255  Hebrew (Windows)  1255 
IBM420  IBM EBCDIC (Arabic)  20420 
IBM880  IBM EBCDIC (Cyrillic Russian)  20880 
cp1025  IBM EBCDIC (Cyrillic Serbian-Bulgarian)  21025 
IBM277  IBM EBCDIC (Denmark-Norway)  20277 
IBM01142  IBM EBCDIC (Denmark-Norway-Euro)  1142 
IBM278  IBM EBCDIC (Finland-Sweden)  20278 
IBM01143  IBM EBCDIC (Finland-Sweden-Euro)  1143 
IBM297  IBM EBCDIC (France)  20297 
IBM01147  IBM EBCDIC (France-Euro)  1147 
IBM273  IBM EBCDIC (Germany)  20273 
IBM01141  IBM EBCDIC (Germany-Euro)  1141 
cp875  IBM EBCDIC (Greek Modern)  875 
IBM423  IBM EBCDIC (Greek)  20423 
IBM424  IBM EBCDIC (Hebrew)  20424 
IBM871  IBM EBCDIC (Icelandic)  20871 
IBM01149  IBM EBCDIC (Icelandic-Euro)  1149 
IBM500  IBM EBCDIC (International)  500 
IBM01148  IBM EBCDIC (International-Euro)  1148 
IBM280  IBM EBCDIC (Italy)  20280 
IBM01144  IBM EBCDIC (Italy-Euro)  1144 
IBM290  IBM EBCDIC (Japanese katakana)  20290 
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x-EBCDIC-KoreanExtended  IBM EBCDIC (Korean Extended)  20833 
IBM870  IBM EBCDIC (Multilingual Latin-2)  870 
IBM284  IBM EBCDIC (Spain)  20284 
IBM01145  IBM EBCDIC (Spain-Euro)  1145 
IBM-Thai  IBM EBCDIC (Thai)  20838 
IBM1026  IBM EBCDIC (Turkish Latin-5)  1026 
IBM905  IBM EBCDIC (Turkish)  20905 
IBM285  IBM EBCDIC (UK)  20285 
IBM01146  IBM EBCDIC (UK-Euro)  1146 
IBM037  IBM EBCDIC (US-Canada)  37 
IBM01140  IBM EBCDIC (US-Canada-Euro)  1140 
IBM01047  IBM Latin-1  1047 
IBM00924  IBM Latin-1  20924 
x-cp20003  IBM5550 Taiwan  20003 
ibm861  Icelandic (DOS)  861 
x-mac-icelandic  Icelandic (Mac)  10079 
x-iscii-as  ISCII Assamese  57006 
x-iscii-be  ISCII Bengali  57003 
x-iscii-de  ISCII Devanagari  57002 
x-iscii-gu  ISCII Gujarati  57010 
x-iscii-ka  ISCII Kannada  57008 
x-iscii-ma  ISCII Malayalam  57009 
x-iscii-or  ISCII Oriya  57007 
x-iscii-pa  ISCII Punjabi  57011 
x-iscii-ta  ISCII Tamil  57004 
x-iscii-te  ISCII Telugu  57005 
x-cp20269  ISO-6937  20269 
euc-jp  Japanese (EUC)  51932 
EUC-JP  Japanese (JIS 0208-1990 and 0212-1990)  20932 
iso-2022-jp  Japanese (JIS)  50220 
iso-2022-jp  Japanese (JIS-Allow 1 byte Kana - SO/SI)  50222 
csISO2022JP  Japanese (JIS-Allow 1 byte Kana)  50221 
x-mac-japanese  Japanese (Mac)  10001 
shift_jis  Japanese (Shift-JIS)  932 
ks_c_5601-1987  Korean  949 
euc-kr  Korean (EUC)  51949 
iso-2022-kr  Korean (ISO)  50225 
Johab  Korean (Johab)  1361 
x-mac-korean  Korean (Mac)  10003 
x-cp20949  Korean Wansung  20949 
iso-8859-3  Latin 3 (ISO)  28593 
iso-8859-15  Latin 9 (ISO)  28605 
IBM865  Nordic (DOS)  865 
x-IA5-Norwegian  Norwegian (IA5)  20108 
IBM855  OEM Cyrillic  855 
IBM00858  OEM Multilingual Latin I  858 
IBM437  OEM United States  437 
IBM860  Portuguese (DOS)  860 
x-mac-romanian  Romanian (Mac)  10010 
x-IA5-Swedish  Swedish (IA5)  20107 
x-cp20261  T.61  20261 
x-cp20001  TCA Taiwan  20001 
x-cp20004  TeleText Taiwan  20004 
x-mac-thai  Thai (Mac)  10021 
windows-874  Thai (Windows)  874 
ibm857  Turkish (DOS)  857 
iso-8859-9  Turkish (ISO)  28599 
x-mac-turkish  Turkish (Mac)  10081 
windows-1254  Turkish (Windows)  1254 
x-mac-ukrainian  Ukrainian (Mac)  10017 
utf-16  Unicode  1200 
unicodeFFFE  Unicode (Big-Endian)  1201 
utf-32BE  Unicode (UTF-32 Big-Endian)  65006 
utf-32  Unicode (UTF-32)  65005 
utf-7  Unicode (UTF-7)  65000 
utf-8  Unicode (UTF-8)  65001 
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us-ascii  US-ASCII  20127 
windows-1258  Vietnamese (Windows)  1258 
x-cp20005  Wang Taiwan  20005 
ibm850  Western European (DOS)  850 
x-IA5  Western European (IA5)  20105 
iso-8859-1  Western European (ISO)  28591 
macintosh  Western European (Mac)  10000 
Windows-1252  Western European (Windows)  1252 

Languages List  

 
Language Code Encoding Default Culture name Locale id 
Arabic ARA Arabic (Windows) ar 1 
Arabic (Saudi Arabia) ARA Arabic (Windows) ar-SA 1025 
Arabic (Iraq) ARI Arabic (Windows) ar-IQ 2049 
Arabic (Egypt) ARE Arabic (Windows) ar-EG 3073 
Arabic (Libya) ARL Arabic (Windows) ar-LY 4097 
Arabic (Algeria) ARG Arabic (Windows) ar-DZ 5121 
Arabic (Morocco) ARM Arabic (Windows) ar-MA 6145 
Arabic (Tunisia) ART Arabic (Windows) ar-TN 7169 
Arabic (Oman) ARO Arabic (Windows) ar-OM 8193 
Arabic (Yemen) ARY Arabic (Windows) ar-YE 9217 
Arabic (Syria) ARS Arabic (Windows) ar-SY 10241 
Arabic (Jordan) ARJ Arabic (Windows) ar-JO 11265 
Arabic (Lebanon) ARB Arabic (Windows) ar-LB 12289 
Arabic (Kuwait) ARK Arabic (Windows) ar-KW 13313 
Arabic (U.A.E.) ARU Arabic (Windows) ar-AE 14337 
Arabic (Bahrain) ARH Arabic (Windows) ar-BH 15361 
Arabic (Qatar) ARQ Arabic (Windows) ar-QA 16385 
Bulgarian BGR Cyrillic (Windows) bg 2 
Bulgarian (Bulgaria) BGR Cyrillic (Windows) bg-BG 1026 
Catalan CAT Western European (Windows) ca 3 
Catalan (Catalan) CAT Western European (Windows) ca-ES 1027 
Chinese (Simplified) CHS Chinese Simplified (EUC) zh-CHS 4 
Chinese (Taiwan) CHT TCA Taiwan zh-TW 1028 
Chinese (People's Republic of China) CHS Chinese Simplified (EUC) zh-CN 2052 
Chinese (Hong Kong S.A.R.) ZHH Chinese Simplified (EUC) zh-HK 3076 
Chinese (Singapore) ZHI Chinese Simplified (EUC) zh-SG 4100 
Chinese (Macau S.A.R.) ZHM Chinese Simplified (EUC) zh-MO 5124 
Chinese (Traditional) CHT Chinese Traditional (Big5) zh-CHT 31748 
Czech CSY Central European (Windows) cs 5 
Czech (Czech Republic) CSY Central European (Windows) cs-CZ 1029 
Danish DAN Western European (Windows) da 6 
Danish (Denmark) DAN Western European (Windows) da-DK 1030 
German DEU Western European (Windows) de 7 
German (Germany) DEU Western European (Windows) de-DE 1031 
German (Switzerland) DES Western European (Windows) de-CH 2055 
German (Austria) DEA Western European (Windows) de-AT 3079 
German (Luxembourg) DEL Western European (Windows) de-LU 4103 
German (Liechtenstein) DEC Western European (Windows) de-LI 5127 
Greek ELL Greek (Windows) el 8 
Greek (Greece) ELL Greek (Windows) el-GR 1032 
English ENG Western European (Windows) en 9 
English (United States) ENG Western European (Windows) en-US 1033 
English (United Kingdom) ENG Western European (Windows) en-GB 2057 
English (Australia) ENA Western European (Windows) en-AU 3081 
English (Canada) ENC Western European (Windows) en-CA 4105 
English (New Zealand) ENZ Western European (Windows) en-NZ 5129 
English (Ireland) ENI Western European (Windows) en-IE 6153 
English (South Africa) ENS Western European (Windows) en-ZA 7177 
English (Jamaica) ENJ Western European (Windows) en-JM 8201 
English (Caribbean) ENB Western European (Windows) en-CB 9225 
English (Belize) ENL Western European (Windows) en-BZ 10249 
English (Trinidad and Tobago) ENT Western European (Windows) en-TT 11273 
English (Zimbabwe) ENW Western European (Windows) en-ZW 12297 
English (Republic of the Philippines) ENP Western European (Windows) en-PH 13321 
Spanish ESP Western European (Windows) es 10 
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Spanish (Mexico) ESM Western European (Windows) es-MX 2058 
Spanish (Spain) ESN Western European (Windows) es-ES 3082 
Spanish (Guatemala) ESG Western European (Windows) es-GT 4106 
Spanish (Costa Rica) ESC Western European (Windows) es-CR 5130 
Spanish (Panama) ESA Western European (Windows) es-PA 6154 
Spanish (Dominican Republic) ESD Western European (Windows) es-DO 7178 
Spanish (Venezuela) ESV Western European (Windows) es-VE 8202 
Spanish (Colombia) ESO Western European (Windows) es-CO 9226 
Spanish (Peru) ESR Western European (Windows) es-PE 10250 
Spanish (Argentina) ESS Western European (Windows) es-AR 11274 
Spanish (Ecuador) ESF Western European (Windows) es-EC 12298 
Spanish (Chile) ESL Western European (Windows) es-CL 13322 
Spanish (Uruguay) ESY Western European (Windows) es-UY 14346 
Spanish (Paraguay) ESZ Western European (Windows) es-PY 15370 
Spanish (Bolivia) ESB Western European (Windows) es-BO 16394 
Spanish (El Salvador) ESE Western European (Windows) es-SV 17418 
Spanish (Honduras) ESH Western European (Windows) es-HN 18442 
Spanish (Nicaragua) ESI Western European (Windows) es-NI 19466 
Spanish (Puerto Rico) ESU Western European (Windows) es-PR 20490 
Finnish FIN Western European (Windows) fi 11 
Finnish (Finland) FIN Western European (Windows) fi-FI 1035 
French FRA Western European (Windows) fr 12 
French (France) FRA Western European (Windows) fr-FR 1036 
French (Belgium) FRB Western European (Windows) fr-BE 2060 
French (Canada) FRC Western European (Windows) fr-CA 3084 
French (Switzerland) FRS Western European (Windows) fr-CH 4108 
French (Luxembourg) FRL Western European (Windows) fr-LU 5132 
French (Principality of Monaco) FRM Western European (Windows) fr-MC 6156 
Hebrew HEB Hebrew (Windows) he 13 
Hebrew (Israel) HEB Hebrew (Windows) he-IL 1037 
Hungarian HUN Central European (Windows) hu 14 
Hungarian (Hungary) HUN Central European (Windows) hu-HU 1038 
Icelandic ISL Western European (Windows) is 15 
Icelandic (Iceland) ISL Western European (Windows) is-IS 1039 
Italian ITA Western European (Windows) it 16 
Italian (Italy) ITA Western European (Windows) it-IT 1040 
Italian (Switzerland) ITS Western European (Windows) it-CH 2064 
Japanese JPN Western European (Windows) ja 17 
Japanese (Japan) JPN Western European (Windows) ja-JP 1041 
Korean KOR Korean ko 18 
Korean (Korea) KOR Korean ko-KR 1042 
Dutch NLD Western European (Windows) nl 19 
Dutch (Netherlands) NLD Western European (Windows) nl-NL 1043 
Dutch (Belgium) NLB Western European (Windows) nl-BE 2067 
Norwegian NOR Western European (Windows) no 20 
Polish PLK Central European (Windows) pl 21 
Portuguese PTB Western European (Windows) pt 22 
Romanian ROM Central European (Windows) ro 24 
Russian RUS Cyrillic (Windows) ru 25 
Croatian HRV Central European (Windows) hr 26 
Serbian (Latin) (Serbia) SRL Central European (Windows) sr-SP-Latn 2074 
Serbian (Cyrillic) (Serbia) SRB Cyrillic (Windows) sr-SP-Cyrl 3098 
Slovak SKY Central European (Windows) sk 27 
Albanian SQI Central European (Windows) sq 28 
Swedish SVE Western European (Windows) sv 29 
Swedish (Finland) SVF Western European (Windows) sv-FI 2077 
Thai THA Thai (Windows) th 30 
Turkish TRK Turkish (Windows) tr 31 
Urdu URD Unicode ur 32 
Urdu (Islamic Republic of Pakistan) URD Unicode ur-PK 1056 
Indonesian IND Unicode id 33 
Ukrainian UKR Cyrillic (Windows) uk 34 
Belarusian BEL Cyrillic (Windows) be 35 
Slovenian SLV Western European (Windows) sl 36 
Estonian ETI Baltic (Windows) et 37 
Latvian LVI Baltic (Windows) lv 38 
Lithuanian LTH Baltic (Windows) lt 39 
Farsi FAR Unicode fa 41 
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Vietnamese VIT Vietnamese (Windows) vi 42 
Armenian HYE Unicode hy 43 
Azeri AZE Unicode az 44 
Azeri (Latin) (Azerbaijan) AZE Unicode az-AZ-Latn 1068 
Azeri (Cyrillic) (Azerbaijan) AZE Unicode az-AZ-Cyrl 2092 
Basque EUQ Western European (Windows) eu 45 
FYRO Macedonian MKI Unicode mk 47 
Afrikaans AFK Unicode af 54 
Georgian KAT Unicode ka 55 
Faroese FOS Unicode fo 56 
Hindi HIN Unicode hi 57 
Malay MSL Unicode ms 62 
Malay (Brunei Darussalam) MSB Unicode ms-BN 2110 
Kazakh KKZ Unicode kk 63 
Kyrgyz KYR Unicode ky 64 
Swahili SWK Unicode sw 65 
Uzbek UZB Unicode uz 67 
Uzbek (Latin) (Uzbekistan) UZB Unicode uz-UZ-Latn 1091 
Uzbek (Cyrillic) (Uzbekistan) UZB Unicode uz-UZ-Cyrl 2115 
Tatar TTT Unicode tt 68 
Punjabi PAN Unicode pa 70 
Gujarati GUJ Unicode gu 71 
Gujarati (India) GUJ Unicode gu-IN 1095 
Tamil TAM Unicode ta 73 
Tamil (India) TAM Unicode ta-IN 1097 
Telugu TEL Unicode te 74 
Telugu (India) TEL Unicode te-IN 1098 
Kannada KAN Unicode kn 75 
Kannada (India) KAN Unicode kn-IN 1099 
Marathi MAR Unicode mr 78 
Marathi (India) MAR Unicode mr-IN 1102 
Sanskrit SAN Unicode sa 79 
Sanskrit (India) SAN Unicode sa-IN 1103 
Mongolian MON Unicode mn 80 
Galician GLC Unicode gl 86 
Konkani KNK Unicode kok 87 
Konkani (India) KNK Unicode kok-IN 1111 
Syriac SYR Unicode syr 90 
Syriac (Syria) SYR Unicode syr-SY 1114 
Divehi DIV Unicode div 101 
Divehi (Maldives) DIV Unicode div-MV 1125 
Invariant Language (Invariant Country) IVL Unicode IVL 127 

 

Import Glossary in Excel format into AidTrans Studi o 
Terminology database  

 
Applies to all AidTrans Studio editions.  
 
 
Glossary to import contains six columns: 
 
Ident – identification of a row, 
English Term – term in English, 
German Term – term in German, 
Status – status of current row in glossary, 
Comment – comment for current row, 
Source – origin of current row. 
 
Data source: Ms Excel spreadsheet that contains terminology data in six columns (see screen below). 
 
Data for import: 
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To import data into Terminology database: 
 

1. First you need to create new tdb database in AidTrans Studio format. Run Terminology Database 
Manager, from AidTrans Studio main menu select Tm/Tdb > Tdb Manager 

2. Select File > New, New Tdb Database window pops up. 
 

 
 

3. Select terminology database filename, source and target language, 
 

 
4. Go to Database Columns tab, to make terminology database structure compliant with Excel 

glossary we need to add following columns: Status, Source, Comment and Ident. 
 
 
To add column to terminology database structure click New Column  button, on the Database columns tab. 

 
 
Structure modified: 
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5. Click Create Db  button to confirm db creation, Terminology Database Manager automatically 
opens created database. 

6. Switch to AidTrans Studio Terminology Database Manager main window, select File > Import 
data, Iimport data window pops up. 

 
 

7. In file format list select Ms Excel workbook  item. 
8. Click Browse for import file  button, browse to file for import and click Open button. 
9. Check First row contains column headers  checkbox, in Worksheet to import data  select 

Glossary as this worksheet contains all the data for import. 
10. Go to Columns Mapping  tab, for each source column in excel file you need to set column in 

terminology database to copy data to. 

 
 

11.  Check Allow set selected columns values manually check box, to enable manual values for 
selected columns (all rows imported will have the same value - the one put in Value box).  

 
12.  Click Start Import button to start actual import process, when import is completed you should see 

imported data in Terminology Manager main grid: 
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Hint: 
In the main grid by default there are only two columns visible TextSrc and TextTgt, to select columns to 
display click Visible Columns  button and click on column name you wish to display in grid. 
 

How to create four languages Glossary in AidTrans 
Studio Terminology Database Manager?  

 
Applies to all AidTrans Studio Editions 
 
Glossary languages: English, German, French, Italian with term definition in each language. 
 
By default there are only two languages columns in terminology database, source and target language. 
This is the most common terminology database (tdb) configuration. There is also set of attributes columns 
with additional information useful for terminology database usage. 
 
As in AidTrans Studio you can adjust terminology database structure it is possible to create structure to fit 
four languages. 
 
To customize terminology database structure you need to complete following steps: 

1) Run Terminology Database Manager, i.e. select Tm/Tdb > Tdb Manager in AidTrans Studio Main 
Window 

2) In Terminology Database Manager window select File > New , New Tdb Database window pops up. 
3) Steps to setup glossary file: 
�  Click Browse  button to specify terminology database filename, (e.g. 

Eng_Ger_Fre_Ita_Glossary.atd) 
�  Set source language: English as it is the primary source language for the glossary, 
�  Set target language: German as it is the primary target language for the glossary, 

 
 

4) Select Database Columns tab, to define terminology database structure: 
 

�  In TextSrc description put text: English term  to indicate what data column will contain, 
�  In TextTgt description put text: German term , 
�  Create column named FrenchTerm  with description FrenchTerm , 
�  Create column named ItalianTerm  with description ItalianTerm , 
�  Create columns: Definition_English, Definition_German, Definition_French, Definition_Italian, to 

store definitions in each language of the glossary, 
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Once the structure definition is completed click the Create Db  button. 
 
The terminology database created is prepared to be used in projects that source language is English and 
target language is German. How to modify tdb to use with projects in other language combinations e.g.  
from French into Italian: 
 

1. In Terminology Database Manager main window, run Tools > Tdb Database Settings or click  
button on main toolbar.  Go to Db columns tab, select the row in columns list grid that you wish to 
be the source column, (column FrenchTerm in our example), 

 

 
2. Click Utilities button, and select Set selected column as Source column  context menu item, 
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3. Click yes on three dialog boxes that will pop up when completing the source column change 
operation,   

4. Select the row in columns list grid that you wish to be the target column, (column ItalianTerm in our 
example), 

5. Click Utilities button, and select Set selected column as Target column  context menu item,  
6. Click yes on three dialog boxes that will pop up when completing the target column change 

operation, 

 
Note that for previous source and target columns, new column name was copied from its description, so 
make sure to set proper description for each column before changing the source language column. 
 
For new source and target columns, previous name is copied to its description so it is clear what data is 
stored in the column. 

Glossary of Terms 

CAT tool 
CAT stands for Computer Aided Translation. CAT is a technology that supports translators when 
translating, automates some parts of the translation process. 

Main categories of  CAT tools: 

1. translation memory tools, 

2. software localization tools, 

3. terminology management tools. 

Export 
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To export files it is to extract translated text from .ats file where the actual translation process is done to 
target file format.  

In Tm/Tdb data management means extract data from translation memory or terminology database to some 
othe format. 

 

Pre-Translation 
Pre Translation is a process of searching in translation memory database similar sentences for each 
sentence in source document. Pre Translation is performed when preparing source document for 
translation. 

Proofable segment 
Segment with status other then proofread, i.e. that needs to be proofread. 

SQL 
Structured Query Language, language to communicate with database. Extract or update data and database 
objects. 

Tm 
Tm stands for translation memory. It is a short form for both translation memory as a technology, and also 
short form for translation memory database.  

Translatable segment 
 

Segment that requires processing by translator. Following segments types are considered translatable:  

-          untranslated  ‘_’ 

-          fuzzy, 

-          pending/doubtful, 

-          exact matches (if Exact matches considered translatable option is set to true) 

Placeable 
Placeable is translation segment fragment that should not be translated. Usually these are: proper names, 
numbers, non translatable characters or expressions. See example below:  
Source text: The MatrixExt sequence starts from 400 up to 600 with step 2.  
Translation: MatrixExt <text> 400 <text> 600 <text> 2. 
There are three numbers: 400, 600 and 2, and proper name: MatrixExt that are not to be translated. 

In AidTrans Studio, expressions recognized as placeables are encapsulated within �  �  characters. Note that 
placeables handling in AidTrans Studio is fully configurable. 

Terminology database 
It is a database that stores single terms or expressions, their translation in the target language. 
It can also contain some additional information:  
- linguistics information: gender, part of speech 
- other: project name, client name, date when translation was done. 
Short name for terminology database is term database, or just tdb. 

Tdb 
Tdb stands for terminology database. It stores terms and expressions to be used for reference during the 
translation process. 

Source/target language 
If we have translation from English into Chinese, source language is: English and Target language is 
Chinese.  
It is similar when we speak of translation memory database. 
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Object Tag 
Object tags cannot occur within segment borders. Object tags are always enclosed within: ‘‹’ (code: 
139) and ‘ ›’  (code: 155) characters. 

Sample:  

��  ReadMe� 0_�  ‹<HEAD>› 

��  Configuring «<b>»Internet Protocol «</b>»version X� 1_� ‹</TITLE>› 

Object Tags: ‹</TITLE>› and ‹<HEAD>› 

Segment Tag 
Segment tags are actual segment borders. Each segment start with ��  tag and ends with � <segment 
number><status>� . 

Sample:  

��  ReadMe� 0_�  

 

Internal/Format Tag 
Tags that occur inside segment, usually stand for original text format, or some file format specific 
properties. Sample internal/format tags: «<u>» «</u>», encapsulate standard html underline tag. 

Batching 
Batching  - with import files are assigned to batches, so the translators work on single file instead of many. 

With specific batching options configuration single input file can be splitted into number of batches defined 
by user. 

Local Translation Memory 
Translation Memory database file (file extension: .atm). It can be used only by one user, i.e. when a user 
opens database in Translation Memory Manager it should no be opened by any other user. You can also 
open the file using Microsoft Access. 

Network Translation Memory 
Translation memory database located on a database server (MSDE or SQL Server). The number of users 
that use network Tm at the same time is only limited by database server capability. 

Local Terminology Database 
Terminology database file (file extension: .atd). ). It can be used only by one user, i.e. when a user opens 
database in Terminology Manager it should no be opened by any other user. You can also open the file 
using Microsoft Access. 

Network Terminology Database 
Terminology database located on a database server (MSDE or SQL Server). The number of users that use 
network Tdb at the same time is only limited by database server capability. 

 

WYSIWYG 
What You See Is What You Get. 

Import 
Prepare files for translation. 

In Tm/Tdb data management means conversion of data from some external format to AidTrans Studio 
translation memory or terminology database. 
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